Plexrequests - connectors setup (Sonarr, Couchpotato, etc.)

couchpotato
sonarr
plexrequests
configuration
plex

#1

Hi everyone,

I’m currently testing Quickbox and it’s awesome !
But I need a bit help regarding the Plexrequest’s configuration with other services like Couchpotato, Sonarr, etc.

I think it might be a good idea to explain the default setup for all request services.

For example :

Plex (reinstalled with Plex default settings)
Plex Hostname or IP : ServerIPAdress
SSL : checked
Use Advanced Search (if you want it) : checked
Enable Episode Seaching (if you want it) : checked
Plex Base Url :
Plex Authorization Token (easier with the request token button) : YourPlexTokenNotThisText
Test Connectivity : OK

That works for Plex without issue but regarding the Couchpotato or Sonarr configurations, I tried several parameters without arriving to be OK…

If some of you succeded, could you please tell me how you did it ?

Thanks !

EDIT (with @liara help) :

Sonarr
Sonarr Hostname or IP : localhost
Port : 8989
Sonarr API Key : YourSonarrAPIKEY
Sonarr Base Url : sonarr
Test Connectivity : OK

Couchpotato
CouchPotato Hostname or IP : localhost
Port : 5050
CouchPotato API Key : YourCouchpoatoAPIKEY
CouchPotato Base Url : couchpotato
Test Connectivity : OK


#2

Couchpotato: localhost:5050 baseurl: couchpotato ssl: off
Sickrage: localhost:8081 baseurl: sickrage ssl: off
Sonarr: localhost:8989 baseurl: sonarr ssl: off


#3

Thanks @liara ! :slight_smile:
Everything is configured now


#4

Sorry to resurrect this, if I should start new let me know. I am having this same problem, but liara’s answer isn’t working.


#5

Please post screenshots of your settings. It will help a lot.


#6

#7

Sonarr is the only one I am trying to setup. Would having a login/password setup for Sonarr cause any issues?


#8

No, that’s what the API key is for (but you have left that blank). Make sure you grab your API key from the sonarr settings and it should start to work


#9

I knew I should have said that I left it blank intentionally lol


#10

Try removing the slashes then, they may be interfering with the way Plex Requests constructs the baseurl


#11

Tried that as well. I am in the process of setting up a different VPS. This one has been problematic since the beginning. Should it not work then I’ll take it from there.


#12

i cant get it to work and get this error

Could not connect to SickRage, please check your settings. Exception Message: localhost:sickrage/api/cc35153a78befdde27b37571ad5ca0ac/?cmd=sb.ping""