PlexPy/Tautulli issue (Community Version)

plexpy
tautulli

#1

Yesterdays update seems to have caused a few issues for PlexPy/Tautulli in the community version of QB.

It removed the link to PlexPy in the main menu, but the application can still be accessed by typing the the URL tp xxxxx/plexpy

Installing Tautulli using the package installer, prompt that the install is successful, however the link to Tautulli in the main menu leading to xxxxxxx/tautulli - does not load anything. Also - that is no icon for Tautulli in the main menu.

Let me know if you need any additional data :slight_smile:


#2

I installed tautulli even though I already had plexpy installed.
waited for the script to finish
Then…
just use the old url xxxxx/plexpy
go into settings - web interface
type tautulli into the http root field
save - restart

@dtech the icon is missing within the /srv/rutorrent/home/img/brands folder.


#3

Not Found

The requested URL /tautulli/ was not found on this server.

Is a server reboot also required?

edit: fixed by installing tautulli from PMC and it kept my settings and the opt/plexpy/ folder.


#4

I did a server reboot for unrelated reasons. After that, PlexPy is no longer reachable. Tried a box install plexpy - to no avail.


#5

Think I figured it out, things seems to be case sensitive - in this case, using Tautulli, instead of tautulli did the trick.

Found these under package/install and package/remove:

  • removepackage-Tautulli
  • installpackage-Tautulli
  • installpackage-tautulli

#6

yeah idk why i did that mostly due to them using it in their repo so i just went from there and kept going.


#7

Sorry to anyone this update broke things on, was my bad was more thinking of just updating the installer to make it install the latest ver and then forgot to add in a way for it to move existing settings/installs,
Also need help with the Icon as that was something @jmsolo is a little better with.

side note
This is why i am known as breaker of things :-p


#8

@dtech, check the img/brands directory in the QuickBox Pro repository, it’s stashed there. :wink:


#9

Hi,
i still have an issue with Tautulli, i can open it fine and it shows the stream info but doesn’t show anything else.
tautulli

How can i fix this ?

thanks.


#10

If you have linked it to you Plex server, try using localhost instead of 127.0.0.1 - that worked for me.


#11

What do you mean ?
In the tautulli settings ?

because even the configuration stucks on loading :
tautulli2


#12

Hi guys,

So what is the consensus to get Tautulli to work? I managed to get it removed properly from QB. Should I re-install via QB? or install directly from Git?

Thanks.


#13

I just used box-install-Tautulli via putty - worked like a charm.


#14

Yes, via the settings menu in Tautulli. If it does not load, I guess something is up with either your install or it not running properly.

I’d recommend via putty to run a box-remove-tautulli followed by a box-install-Tautulli - eventually you should be informed to run the Wizard to setup Plex etc.

When done, go to Settings, and hit that “Verity Server” button - and hopefully you should get that little orange checkmark.
image


#15

Yeah Tautulli runs like a charm :slight_smile:
A cleaup script is being looked into for those having plexpy installed and not having the possibility to use the unstaller for that anymore before using the installer for tautulli!


#16

Thanks guys - just an fyi - the command line did not work.

What I ended up doing is a simple box command. Then manually installed from there.


#17

try to remove then install, but can’t acces tautulli, nothing load.
here a systemctl:

(1:79)# systemctl status Tautulli
● Tautulli.service - Tautulli - Stats for Plex Media Server usage
Loaded: loaded (/etc/systemd/system/Tautulli.service; enabled; vendor preset:
Active: inactive (dead) since Tue 2018-06-05 13:31:15 CEST; 1min 20s ago
Process: 29410 ExecStart=/opt/Tautulli/Tautulli.py --quiet --daemon --nolaunch

Jun 05 13:31:14 server-anathros systemd[1]: Starting Tautulli - Stats for Plex M
Jun 05 13:31:14 server-anathros systemd[1]: Started Tautulli - Stats for Plex Me