Plex unreachable outside tunnel

plex

#1

Guys,

I changed my domain, so I’ve done the cert thing again and I managed to get all things and apps up and running except plex.

It’s unreachable, though it’s green and I can access it fine in the tunnel at http://localhost:8888/web/index.html
It says Fully accessible outside your network, even when I tried the tunnel for the same time, it was still green.

It has the same port 34200, but it’s not visible outside tunnel. I tried insecure to always, no dice.
Can you help out a bit here?
Thanks!


#2

Hey there @uneven!

I have seen this happen and have had it happen to myself on several occasions. The best thing to try first is to log out of Plex from all devices, then do a refresh of your browsers cache and attempt to login again. This is usually just a caching issue with Plex caching either the old domain or the old server host.


#3

Hey @JMSolo, unfortunately, it’s not the cache, tried it with 3 different browsers, clear cache and everything, it shows the server’s name but it’s unavailable.

It shows the option to allow it insecure, but it doesn’t help.
That’s a weird one, if anyone could figure it out, I’d appreciate it.

The other option would be to uninstall and re-install it right?
Cheers


#4

Can you guys make something out of this output of service plexmediaserver status

I really really would love if I could avoid wiping and reinstalling the whole server.


#5

Yes, it’s saying it’s running.

When you flushed your browser cache, had you also logged out of Plex completely? All apps, the plex.tv… everything?


#6

Well, I’m a fool.
I’ve tried literally everything and spent about 4 hours. I thought I messed up with letsencrypt since I also used another tutorial. Then I messed up apache2, so I gave up and wiped the server together with 8 TB of seeding torrents.

The funny part, after re-installing QB, same thing. I got so mad when I realized that it was the dreaded uMatrix that wouldn’t let me see my server. I had whitelisted it before, but it was on a different domain.

Well, live and learn, it was right under my nose. My mistake I have it installed on all of my browsers. Oh well…

Thanks JMSolo, too bad I didnt see it earlier.