Plex service unavailable after update

plex
ubuntu

#1

Hi everyone,

I’m facing an issue when I run the “updatePlex” command : I have a “Service Unavailable” afterwards, and the Plex service won’t start.

I’m forced to uninstall and install again Plex, and rebuild all libraries.

What’s wrong in my update process and/or my server?
I see there’s new updates, how can I update Plex without problem?

Thanks a lot for your help !

If any of these information could help…
Ubuntu 16.04.2 LTS
Linux 4.9.58-xxxx-std-ipv6-64 #1 SMP Mon Oct 23 11:35:59 CEST 2017 x86_64 x86_64 x86_64 GNU/Linux
OVH Hosted
Quickbox V2.5.4


#2

Hi,

The updatePlex script is currently outdated and may cause problems while updating the Plex Media Server. I haven’t tested this yet but try to uninstall your current version of Plex via quickbox dashboard. Then login to your ssh and try to sudo apt-get update. By doing this, your package database will updated to download the latest version of PMS on your next install. After that, install Plex again on your quickbox.

Please let me know if this will work for you


#3

Hi melo,

Thanks for your answer.
We’ve already tried this by uninstalling and install again with the quickbox dashboard. The problem is we lost all the librairies and settings (seen movies, etc.) everytime.
Do you know how can we update Plex without losing all of the librairies and settings?

Thank you for your help


#4

You can perform an archive of your Plex directory
zip -R /var/lib/plexmediaserver /your_desired_folder/backupPlex.zip

I do this every month to prevent metadata loose.

If you have problem with a Plex Update, you just have to delete the /var/lib/plexmediaserver directory and make

unzip -R /your_desired_folder/backupPlex.zip /var/lib/plexmediaserver
chown -R plex:plex /var/lib/plexmediaserver/
systemctl restart plexmediaserver.service

And Voila ! You have restoring your database, settings & metadata. The only datas losed by this operation are the already watched medias. But when you have almost 8Tb of medias, loosing these datas is not so serious :slight_smile: