Plex Requests connection issue to Plex


#1

Hi guys

I said I’d check out Plex Requests in the new update, it seems to work well, it’s connected to Sonarr. I was able to process a request. However I cannot connect to my Plex server. I’ve tried the IP with ssl selected and not selected and localhost with the ssl selected and not selected. I’m using port 32400.

I’ve gone through the authenticity part and I fetched the token. So I’ve no idea what’s going on.

The plex server is online, and I have been able to access it via IP:32400/web

Any ideas? Thanks


#2

After the new update 2.4.2 they changed the port to 31400 :slight_smile:

Another feature we thought to throw in was some Plex Media Server enhancements. Basically, before with default plex there is the sometimes complicated task of creating a local tunnel via ssh to encrypt and forward your Plex connection to you local media server and/or plex.tv. @liara has done some wax on / wax off to get you right in the spot light with a little bit of Proxy magic in Apache. Plex is now located on port :31400 and this bypasses the need for creating a tunnel… we’ve essentially done it for you. This update is reflected on your dashboards as well… so no worries


#3

Changing the port I get this error

Error SecureChannelFailure


#4

You should be able to leave the port to 32400… the 31400 is just a proxy to avoid having to create a local tunnel.

@smilingheadcase, are you on version 2.4.2? If this is the case you will no longer be able to access Plex on 32400 as it now reverses it to 31400 as the listening port. This does not however, change the port 32400 as Plex still operates with the port as normal… therefore, there should be no need to use port 31400 anywhere other than accessing from your dashboard.


#5

Yup, I updated this morning. It’s a strange one. I’ve tried all combinations at this stage. Between using 32400 with localhost and the IP and also trying port 31400.


#6

Mark this as solved, and Mark me as a giant ding dong.

Under the “Plex SubDirectory” setting I put in the the path to the Plex library. This was causing the issue. Leaving this blank, and Plex Requests links up without issue to Plex.


#7

Oh nice! I’m glad you found this as I was looking and looking and couldn’t figure out why it wouldn’t work for you. I’m going to bookmark this for the inclusion of an upcoming FAQ section, it’ll highlight some of the best topics /finds from QuickBox users.

Again, Good Spot! :slight_smile:


#8

This was confusing I kept having problems connecting to plex outside my network and then realized the external port still needs to be 32400 and not 31400.