Plex Request NET don't work

debian8
v2.4.6
plexrequests

#1

Hello everybody,

I just found QuickBox and I find it wonderful! Thank you all!

I have a little problem with Plex Request.NET that does not work. I conducted several test and resettlement before my machine and it worked. But now it no longer works. The “Service status” turns red, and I’m the install / uninstall or do a “Refresh”, impossible to launch the …

It connects to the port 3000 and have the page: “Connection failed”

When I try to run it via ssh with “mono PlexRequests.exe” I have this error message:

Starting Up! Please wait, this can usually take A Few seconds.
Version: 1.9.0
Location of the database: /opt/plexrequests/PlexRequests.sqlite
Error loading kind TypeSpec from 0x1b000036 due to Could not resolve TypeSpec token 1b000036

Thank you for your help.


#2

Could you tell me what the output of systemctl status plexrequests is.

Please wrap the output in </> (code brackets) - you may additionally highlight the text and do Ctrl+Shift+C on your keyboard.


#3

Yes, of course, I have this message:

dzouda:/opt# systemctl status plexrequests
● plexrequests.service
   Loaded: loaded (/etc/systemd/system/plexrequests.service; enabled)
   Active: inactive (dead) since Tue 2016-08-23 15:31:21 CEST; 2s ago
  Process: 16264 ExecStop=/bin/kill -HUP (code=exited, status=1/FAILURE)
  Process: 16053 ExecStart=/usr/bin/screen -f -a -d -m -S plexrequests mono /opt/plexrequests/PlexRequests.exe -p 3000 (code=exited, status=0/SUCCESS)
 Main PID: 16054 (code=exited, status=0/SUCCESS)

Aug 23 15:31:21 ndd.net kill[16264]: kill [options] <pid> [...]
Aug 23 15:31:21 ndd.net kill[16264]: Options:
Aug 23 15:31:21 ndd.net kill[16264]: <pid> [...]            send signal to every <pid> listed
Aug 23 15:31:21 ndd.net kill[16264]: -<signal>, -s, --signal <signal>
Aug 23 15:31:21 ndd.net kill[16264]: specify the <signal> to be sent
Aug 23 15:31:21 ndd.net kill[16264]: -l, --list=[<signal>]  list all signal names, or convert one ...name
Aug 23 15:31:21 ndd.net kill[16264]: -L, --table            list all signal names in a nice table
Aug 23 15:31:21 ndd.net kill[16264]: -h, --help     display this help and exit
Aug 23 15:31:21 ndd.net kill[16264]: -V, --version  output version information and exit
Aug 23 15:31:21 ndd.net kill[16264]: For more details see kill(1).
Hint: Some lines were ellipsized, use -l to show in full.

#4

Does it come back to active status after doing systemctl restart plexrequests

Also, are you on Debian or Ubuntu?


#5

No, this command changes nothing. I still have the error message and Plex Request does not.

I’m on debian.


#6

Can you check your apache logs to see if there is an error present within. I had this confirmed with a beta tester that they have this same issue on a Debian install… so it seems this is isolated to Debian only as Ubuntu installs are fine.

Try to also toggle the service off on your dashboard (if the switch says Enabled). Had you done any apt-get updates/upgrades recently?


#7

Bahhh… don’t worry, I have swith to Ubuntu and it’s work perfectly!

Thanks you JMSolo


#8

Glad Ubuntu sorted you out. Nonetheless, I appreciate your report on this. I am going to spend some time later this afternoon replicating and troubleshooting this issue.


#9

I’m wondering if it could be a mono issue, similar to the Jackett issues recently experienced by some


#10

same issue here on my Deb install

TheBox:~# systemctl status plexrequests
● plexrequests.service
   Loaded: loaded (/etc/systemd/system/plexrequests.service; enabled)
   Active: inactive (dead) since Tue 2016-08-23 20:45:33 CEST; 1min 31s ago
  Process: 9562 ExecStop=/bin/kill -HUP (code=exited, status=1/FAILURE)
  Process: 9542 ExecStart=/usr/bin/screen -f -a -d -m -S plexrequests mono /opt/                                               plexrequests/PlexRequests.exe -p 3000 (code=exited, status=0/SUCCESS)
 Main PID: 9543 (code=exited, status=0/SUCCESS)

Aug 23 20:45:33 TheBox kill[9562]: kill [options] <pid> [...]
Aug 23 20:45:33 TheBox kill[9562]: Options:
Aug 23 20:45:33 TheBox kill[9562]: <pid> [...]            send signal to ev...ed
Aug 23 20:45:33 TheBox kill[9562]: -<signal>, -s, --signal <signal>
Aug 23 20:45:33 TheBox kill[9562]: specify the <signal> to be sent
Aug 23 20:45:33 TheBox kill[9562]: -l, --list=[<signal>]  list all signal n...me
Aug 23 20:45:33 TheBox kill[9562]: -L, --table            list all signal n...le
Aug 23 20:45:33 TheBox kill[9562]: -h, --help     display this help and exit
Aug 23 20:45:33 TheBox kill[9562]: -V, --version  output version informatio...it
Aug 23 20:45:33 TheBox kill[9562]: For more details see kill(1).
Hint: Some lines were ellipsized, use -l to show in full.
TheBox:~#

#11

Hey @globber,

Can you test a few things for me?

Please ensure your system is totally up to date:

apt update
apt upgrade

Then please ensure your mono packages are totally installed:

apt install mono-complete mono-devel

And please try running plexrequests again


#12

Just ran some test against this and that is what was happening.

# apt-get install mono-complete
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-complete : Depends: mono-devel (= 4.4.2.11-0xamarin1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then using the install with mono-devel, you can imagine this happened:

# apt-get install mono-complete mono-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  ca-certificates-mono gamin libart-2.0-2 libbonoboui2-0 libbonoboui2-common libgail18 libgamin0 libgnome-keyring-common libgnome-keyring0
  libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0 libgnomeui-common libmono-cscompmgd0.0-cil libmono-smdiagnostics0.0-cil
  libmono-system-data-entity4.0-cil libmono-system-numerics-vectors4.0-cil libmono-system-reflection-context4.0-cil
  libmono-system-runtime-interopservices-runtimeinformation4.0-cil libmono-system-servicemodel-internals0.0-cil libmonosgen-2.0-dev librsvg2-2
  librsvg2-common
The following packages will be upgraded:
  libmono-2.0-1 libmono-2.0-dev libmono-accessibility4.0-cil libmono-cairo4.0-cil libmono-cecil-private-cil libmono-cil-dev
  libmono-codecontracts4.0-cil libmono-compilerservices-symbolwriter4.0-cil libmono-corlib2.0-cil libmono-corlib4.0-cil libmono-corlib4.5-cil
  libmono-csharp4.0c-cil libmono-custommarshalers4.0-cil libmono-data-tds4.0-cil libmono-db2-1.0-cil libmono-debugger-soft4.0a-cil libmono-http4.0-cil
  libmono-i18n-cjk4.0-cil libmono-i18n-mideast4.0-cil libmono-i18n-other4.0-cil libmono-i18n-rare4.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-all
  libmono-i18n4.0-cil libmono-ldap4.0-cil libmono-management4.0-cil libmono-messaging-rabbitmq4.0-cil libmono-messaging4.0-cil
  libmono-microsoft-build-engine4.0-cil libmono-microsoft-build-framework4.0-cil libmono-microsoft-build-tasks-v4.0-4.0-cil
  libmono-microsoft-build-utilities-v4.0-4.0-cil libmono-microsoft-build4.0-cil libmono-microsoft-csharp4.0-cil libmono-microsoft-visualc10.0-cil
  libmono-microsoft-web-infrastructure1.0-cil libmono-oracle4.0-cil libmono-parallel4.0-cil libmono-peapi4.0a-cil libmono-posix4.0-cil libmono-profiler
  libmono-rabbitmq4.0-cil libmono-relaxng4.0-cil libmono-security4.0-cil libmono-sharpzip4.84-cil libmono-simd4.0-cil libmono-sqlite4.0-cil
  libmono-system-componentmodel-composition4.0-cil libmono-system-componentmodel-dataannotations4.0-cil libmono-system-configuration-install4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil libmono-system-data-datasetextensions4.0-cil libmono-system-data-linq4.0-cil
  libmono-system-data-services-client4.0-cil libmono-system-data-services4.0-cil libmono-system-data4.0-cil libmono-system-design4.0-cil
  libmono-system-drawing-design4.0-cil libmono-system-drawing4.0-cil libmono-system-dynamic4.0-cil libmono-system-enterpriseservices4.0-cil
  libmono-system-identitymodel-selectors4.0-cil libmono-system-identitymodel4.0-cil libmono-system-io-compression-filesystem4.0-cil
  libmono-system-io-compression4.0-cil libmono-system-json-microsoft4.0-cil libmono-system-json4.0-cil libmono-system-ldap-protocols4.0-cil
  libmono-system-ldap4.0-cil libmono-system-management4.0-cil libmono-system-messaging4.0-cil libmono-system-net-http-formatting4.0-cil
  libmono-system-net-http-webrequest4.0-cil libmono-system-net-http4.0-cil libmono-system-net4.0-cil libmono-system-numerics4.0-cil
  libmono-system-reactive-core2.2-cil libmono-system-reactive-debugger2.2-cil libmono-system-reactive-experimental2.2-cil
  libmono-system-reactive-interfaces2.2-cil libmono-system-reactive-linq2.2-cil libmono-system-reactive-observable-aliases0.0-cil
  libmono-system-reactive-platformservices2.2-cil libmono-system-reactive-providers2.2-cil libmono-system-reactive-runtime-remoting2.2-cil
  libmono-system-reactive-windows-forms2.2-cil libmono-system-reactive-windows-threading2.2-cil libmono-system-runtime-caching4.0-cil
  libmono-system-runtime-durableinstancing4.0-cil libmono-system-runtime-serialization-formatters-soap4.0-cil
  libmono-system-runtime-serialization4.0-cil libmono-system-runtime4.0-cil libmono-system-security4.0-cil
  libmono-system-servicemodel-activation4.0-cil libmono-system-servicemodel-discovery4.0-cil libmono-system-servicemodel-routing4.0-cil
  libmono-system-servicemodel-web4.0-cil libmono-system-servicemodel4.0a-cil libmono-system-serviceprocess4.0-cil
  libmono-system-threading-tasks-dataflow4.0-cil libmono-system-transactions4.0-cil libmono-system-web-abstractions4.0-cil
  libmono-system-web-applicationservices4.0-cil libmono-system-web-dynamicdata4.0-cil libmono-system-web-extensions-design4.0-cil
  libmono-system-web-extensions4.0-cil libmono-system-web-http-selfhost4.0-cil libmono-system-web-http-webhost4.0-cil libmono-system-web-http4.0-cil
  libmono-system-web-mvc3.0-cil libmono-system-web-razor2.0-cil libmono-system-web-routing4.0-cil libmono-system-web-services4.0-cil
  libmono-system-web-webpages-deployment2.0-cil libmono-system-web-webpages-razor2.0-cil libmono-system-web-webpages2.0-cil libmono-system-web4.0-cil
  libmono-system-windows-forms-datavisualization4.0a-cil libmono-system-windows-forms4.0-cil libmono-system-windows4.0-cil libmono-system-xaml4.0-cil
  libmono-system-xml-linq4.0-cil libmono-system-xml-serialization4.0-cil libmono-system-xml4.0-cil libmono-system2.0-cil libmono-system4.0-cil
  libmono-tasklets4.0-cil libmono-webbrowser4.0-cil libmono-webmatrix-data4.0-cil libmono-windowsbase4.0-cil libmono-xbuild-tasks4.0-cil
  libmonoboehm-2.0-1 libmonoboehm-2.0-dev libmonosgen-2.0-1 mono-4.0-gac mono-4.0-service mono-complete mono-csharp-shell mono-devel mono-gac mono-jay
  mono-mcs mono-runtime mono-runtime-common mono-runtime-sgen mono-utils mono-xbuild monodoc-base monodoc-manual
150 upgraded, 23 newly installed, 44 to remove and 8 not upgraded.
Need to get 71.4 MB of archives.
After this operation, 46.2 MB of additional disk space will be used.
Do you want to continue? [Y/n]

After updating/upgrading was completed I can confirm that Plex Requests is now running without issue.

# systemctl status plexrequests
● plexrequests.service
   Loaded: loaded (/etc/systemd/system/plexrequests.service; enabled)
   Active: active (running) since Tue 2016-08-23 14:29:56 CDT; 11s ago
  Process: 11813 ExecStart=/usr/bin/screen -f -a -d -m -S plexrequests mono /opt/plexrequests/PlexRequests.exe -p 3000 (code=exited, status=0/SUCCESS)
 Main PID: 11814 (screen)
   CGroup: /system.slice/plexrequests.service
           ├─11814 /usr/bin/SCREEN -f -a -d -m -S plexrequests mono /opt/plexrequests/PlexRequests.exe -p 3000
           └─11815 mono /opt/plexrequests/PlexRequests.exe -p 3000

It looks like we need to address this on the installer:

  apt-get update -q >/dev/null 2>&1
  apt-get install -q -y mono-complete unzip >/dev/null 2>&1

#13

I dislike mono. That is a shit-ton of extra depends :expressionless:

Edit: Wait – upgrades? Seems more like their repo is slightly borked more than anything. Sigh. I will add mono-devel for those few extra depends that are holding back the upgrade/install of mono-complete


#14

I agree. Just about everything you can imagine.

Edit: yes, all 150 of them


#15

Well I guess complete should be “complete” Ah well.


#16

Still want me to fire your commands or wait a bit?


#17

No need as I think we have a handle on this.

box upgrade

and try again :slight_smile:


#18

edit:its still dead…

After the
box upgrade

I ran box again and removed and reinstalled

TheBox:~# box
Removing plexrequests
Removed symlink /etc/systemd/system/multi-user.target.wants/plexrequests.service.
Installing plexrequests
Plex Requests Installation Complete!.
TheBox:~#

Finally disabled/enabled the serice controller…

Waiting for the website to show though…

Nahh turned red…still dead!


#19

Do me a favor @Globber and run the following:

apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
    echo "deb http://download.mono-project.com/repo/debian wheezy main" > /etc/apt/sources.list.d/mono-xamarin.list
    echo "deb http://download.mono-project.com/repo/debian wheezy-libjpeg62-compat main" >> /etc/apt/sources.list.d/mono-xamarin.list
    echo "deb http://download.mono-project.com/repo/debian wheezy-apache24-compat main" >> /etc/apt/sources.list.d/mono-xamarin.list
apt-get update
apt-get install -y mono-complete mono-devel
systemctl restart plexrequests

#20

Its now alive and running like a charm! :slight_smile: