Plex proxy problem

plexmediaserver
plex
16.04
ubuntu

#1

hello all i have a problem i got a new version of plex pass i put back my plex.conf so i can use my subdomain name.
But my problem is now when i enter my subdomain for plex they ask me my username and password for quickbox
How can i skip the username password

This is my plex.conf file

VirtualHost *:443>
ServerName plex.hebergement-qc.com

Proxy *>
Order deny,allow
Allow from all
/Proxy>

Location /web>
ProxyPass http://10.0.0.31:32400/web
ProxyPassReverse http://10.0.0.31:32400/web
/Location>

Location /system>
ProxyPass http://10.0.0.31:32400/system
ProxyPassReverse http://10.0.0.31:32400/system
/Location>

Location /servers>
ProxyPass http://10.0.0.31:32400/servers
ProxyPassReverse http://10.0.0.31:32400/servers
/Location>

Location /accounts>
ProxyPass http://10.0.0.31:32400/accounts
ProxyPassReverse http://10.0.0.31:32400/accounts
/Location>

Location /myplex>
ProxyPass http://10.0.0.31:32400/myplex
ProxyPassReverse http://10.0.0.31:32400/myplex
/Location>

Location /photo>
ProxyPass http://10.0.0.31:32400/photo
ProxyPassReverse http://10.0.0.31:32400/photo
/Location>

Location /clients>
ProxyPass http://10.0.0.31:32400/clients
ProxyPassReverse http://10.0.0.31:32400/clients
/Location>
RewriteEngine on
RewriteCond %{REQUEST_URI} !^/web
RewriteCond %{HTTP:X-Plex-Device} ^$
RewriteRule ^/$ /web/$1 [R,L]
SSLEngine On
SSLCertificateFile /etc/ssl/certs/plex_hebergement-qc_com.crt
SSLCertificateKeyFile /etc/ssl/certs/plex_hebergement-qc_com.key
/VirtualHost>

I know they miss < but it’s don’t appear in the post


#2

This is located within your apache plex.conf file at /etc/apache2/sites-enabled/plex.conf

I am not sure where your plex.conf is located and it looks as if you modified this on your own, as this is the QuickBox version below.

Remove and/or comment out the Auth fields from the config.

###From this

    AuthType Digest
    AuthName "rutorrent"
    AuthUserFile '/etc/htpasswd'
    Require valid-user

###To this

LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so
<VirtualHost *:31400>
  ProxyRequests Off
  ProxyPreserveHost On
  <Proxy *>
    AddDefaultCharset Off
    Order deny,allow
    Allow from all
    #AuthType Digest
    #AuthName "rutorrent"
    #AuthUserFile '/etc/htpasswd'
    #Require valid-user
  </Proxy>
  ProxyPass / http://yourserverip:32400/
  ProxyPassReverse / http://yourserverip:32400/
</VirtualHost>
<IfModule mod_proxy.c>
    Listen 31400
</IfModule>

Be sure to do service apache2 restart after editing.


#3

ok but if i wanna use 443 for my certificate can i use it??


#4

You can with your modified version. I am having a hard time understanding where you placed your plex.conf. You could essentially just name the one QuickBox created to plex.conf.BAK and then use yours with SSL. I tend to not SSL plex on my own server as I use the app.plex.tv for encrypted connections. Just makes things easier and avoids needing to use bulky proxy configurations.


#5

ok sorry i put my plex.conf in /etc/apache2/sites-enable i rename the plex.conf in .bak but when i use 443 port when if i don’t write AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd’
Require valid-user
he ask me my username password of quickbox
but if you tell me it’s easier to pass by app.plex.tv i’m ok with that