Plex issues with initial setup!


#1

Having nothing but grief trying to get plex setup. Tried SSH tunneling, doesn’t work. When I try to setup the server the first time, it gives an error that settings cannot be saved. Then if I try to claim it with my plex.tv account, it doesn’t connect. Tried all kinds of different ways… nothing works!


#2

How I set it up recently

  • Enable x2go
  • Connect into the server via x2go
  • open up a browser and point it to http://localhost:32400
  • add my account

I then went to configure things and got the settings can’t be saved.

I went to my local browser, opened up plex.tv and then went to my new server and changed my settings, added the Movies, etc.


#3

the key is once you can start making setting changes logout of your plex from the top right corner and then claim server.


#4

Can’t connect to my server using x2go on OS X. Any ideas? It gives a timeout error.


#5

I have the same issue and I am unable to follow the Plex SSH tutorial because it uses putty and not a Mac option.


#6

There are tunnel instructions for all OSs on this page: https://support.plex.tv/hc/en-us/articles/200288586-Installation

Time out error would maybe related to a typo or perhaps the client not being able to find the x2go server. However mac os is something that I cannot personally troubleshoot as I don’t have access to a mac.


#7

It looks like this might be the command that is necessary. I’ll try this out.

OS X or Linux

Open a Terminal window or your command prompt
Enter the following command (substituting the IP address of your server as appropriate):
ssh ip.address.of.server -L 8888:localhost:32400
Open a browser window
Type http://localhost:8888/web into the address bar
The browser will connect to the server as if it were local and load Plex Web App

Edit: I did this and got my plex working. Thanks for the link!


#8

Turns out I needed to install Xquartz in addition to the x2go client on OS X. Works fine now.