Plex has crashed

plex

#1

My PMS crashed this morning and I have NO clue why. The only thing I can see the logs is the following error:

ERROR - Network Service: Error in browser handle read: 125 (Operation canceled) socket=-1

Quickbox: V2.3.7
Plex Media Server Version: 1.0.1.2396
Platform: Ubuntu 16.04

I’ve attached the log file. Please could you have a look and see what the problem might be?
Plex Media Server.log (24.5 KB) :: Redacted


#2

Things I’ve tried since my initial post.

  • Rebooted the server few times in the hope that it will magically solve the problem
  • Manually updated to the latest version of PMS (This replaced the config file with the default one but I backed up the script version and just replaced it after the update)
  • I’ve located the crash report but I don’t know how to read it. It’s a .dmp file, not sure what to do with it.

The PMS is still down :frowning: ARGH :rage:, I wish the logs were clearer with what the problem is.

Next I’m going to try to restore Plex from CrashPlan, for yesterday’s backup. I’ve never done this before, hope it works.
if that doesn’t work, the last resort will be to re-install Plex :disappointed:


#3

Have you tried using another browser?


#4

Additionally I am curious as to what the Apache error logs may be producing. Also, are you using any additional plug-ins with Plex, any new devices joined, any Libraries recently removed?


#5

Yes I have.

I’ve solved the problem. Restored Plex via CrashPlan (simply restore /var/lib/plexmediaserver/Library/Application Support/Plex Media Server from yesterday’s backup).

I’m still curious as to what caused the crash though. I’ve posted my logs on the Plex forums too, hopefully they can give some insight.


#6

The problem starts here:

NetworkService: Browsing on interface xxx.xx.xx.xxx on broadcast address xxx.255.255.250 (index: 0)
Network Service: Error in browser handle read: 125 (Operation canceled) socket=-1
Network Service: Abandoning browse socket, it was closed.
Device: ubuntu PC x86_64

However, I am not too certain why this would happen.

Also, I have removed your logs as they are full of device IP. :blush:


#7

Thanks for that.

Was going to tackle upgrading the server to latest version of QuickBox today but I think I’ll put that on the back-burner for now. Too scared to make changes right now :confused:


#8

In all honesty, the newer version v2.4.2 is by far better than it’s previous iterations. There are some directory changes that have been made to make the future scheme much easier to read. Most of the work is done by the script, there are only a couple of tasks that need to be performed manually to have you on point. Basically, with the introduction of 2.4 we have hit an official milestone of stability and after that, there will be no major adjustments to directory trees etc.

If you need any help with the process, just shoot me a PM and I will gladly offer an assist. :slight_smile: