Plex fails to stream

plex

#1

Hi.

First off, I am new to QuickBox and pretty green when it comes to linux. I am on a Kimsufi dedicated box. I couldn’t get the Ubuntu installer to work, can’t remember why now, it was a while ago. The Debian install is working peachy and ruTorrent is working and I have installed Plex through ‘box install plex’ in the terminal.

Plex launches and I have claimed the server and all that jazz. I can stream the video through the plex android app when it uses ‘direct stream’. The problem I come across is when I go to use the PS4 app or the web browser. It says “There was a problem playing this item.” I have tried different videos and have reinstalled plex.

I have attached the log files HERE.

2 things grab my attention. 1st is in the Media Server Log:
> ERROR - MDE: video has no video stream

ERROR - Streaming Resource: Cannot make a decision because either the file is unplayable or the client provided bad data

And the 2nd is at the start of the Scanner Analysis log:

INFO - Plex Media Scanner v1.1.4.2757-24ffd60 - ubuntu PC x86_64 - build: linux-ubuntu-x86_64 - GMT -04:00

Does it matter that it says Ubuntu build and this is running Debian? I know they are similar but I thought it was interesting. When I ran ‘box remove plex’ to reinstall, there was 3 locations that couldn’t be deleted since they didn’t exist. Thought maybe because they were different distros? Sorry, I’m getting off my original point.

When trying to stream on the android app I see the bandwidth in the dashboard rise, which I’m assuming is it uploading. But when using the web or PS4 app nothing happened. Assuming it has to transcode for those apps and it is struggling/failing to do so? I don’t notice the CPU status change either.

I also come across a problem when going to optimise media. It says it was a metadata problem straight away. I’m hoping all this is just a simple problem, but am confused no one else would be having the same issue as it is all standard from the script.

I would love to hear your ideas and thanks so much for reading this far!


#2

No answers and after wrestling with it for a week I’ve decided to reinstall Ubuntu from scratch and things are working as they should. Feel free to delete thread.