Plex can't find media files


#1

I have been using quickbox + plex for about a month now, and have been loving it. I have been keeping all my media files in the /var/lib/plexmediaserver/ directory up until now, but I ran out of space there, so I just migrated my files over to my /home/falsehonesty/plex/ directory. However, now Plex can’t seem to locate any of the files there. I deleted and remade the plex libraries with the new folder location, but every scan turns up nothing.

I ran these commands JMSolo said in another thread, also to no avail.

username=falsehonesty
usermod -a -G ${username} plex
chown ${username}:plex /home/${username}
chmod 750 /home/${username}
setfacl -m g:${username}:rwx /home/${username}

This is the ls -al of the /home/falsehonesty directory http://i66.tinypic.com/25so8eb.png
and this is the ls -al of the /home/falsehonesty/plex directory http://i63.tinypic.com/2cz23bd.png

Any ideas on how to get Plex to pick up my files?


#2

it is good you moved the files out of /var/ as most installs do not set very much space aside for / directory by default. now for plex you should really have separate directories for TV and Movies so that you can use the separate scanners to find the files. how are your libraries setup now?

I am assuming those are all directories which the media files are located in? they all say 4.0K in size. are there actually media files inside of the folders?


#3

I should make separate directories, but its a pain because I would need to retype /Movies or whatever into rutorrent’s destination every time I’m downloading. Do you happen to know any way to make that easier? And thanks for your help, but I just managed to get it working by uninstalling plex and reinstalling. Thanks anyways!


#4

if you make the folders inside of /home/falsehonesty/torrents/rtorrent when you click the drop box in rtorrent while adding a new torrent it will show Movies and TV by default. you could also change the default download directory for rutorrent to /home/falsehonesty/plex/ and put the movies/tv folders in there if that trips your trigger. mine looks like this: https://i.imgur.com/dyi4Uvb.png