Openvpn not starting on ubuntu 16.04

openvpn
server
ubuntu

#1

OS is ubuntu 16.04.1, openvz vps. Openvpn install went smooth, but service wont start with systemd. I even tried commenting nlimitproc line that is suggested for debian.

I have tun device, and just to clarify, starting openvpn manually (sudo openvpn --config /etc/openvpn/server.conf) works flawlessly, so config seems fine. There is something else wrong, and errors in journalctl are not descriptive enough for me to investigate further :slight_smile:

Nov 22 07:16:00 us2 systemd[1]: Starting OpenVPN service...
Nov 22 07:16:00 us2 systemd[1]: Starting OpenVPN connection to server...
Nov 22 07:16:00 us2 ovpn-server[14047]: OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Jun 22 2017
Nov 22 07:16:00 us2 ovpn-server[14047]: library versions: OpenSSL 1.0.2g  1 Mar 2016, LZO 2.08
Nov 22 07:16:00 us2 ovpn-server[14047]: daemon() failed or unsupported: Resource temporarily unavailable (errno=11)
Nov 22 07:16:00 us2 ovpn-server[14047]: Exiting due to fatal error
Nov 22 07:16:00 us2 systemd[1]: Started OpenVPN service.
Nov 22 07:16:00 us2 sudo[14043]: pam_unix(sudo:session): session closed for user root
Nov 22 07:16:00 us2 systemd[1]: [email protected]: Control process exited, code=exited status=1
Nov 22 07:16:00 us2 systemd[1]: Failed to start OpenVPN connection to server.
Nov 22 07:16:00 us2 systemd[1]: [email protected]: Unit entered failed state.
Nov 22 07:16:00 us2 systemd[1]: [email protected]: Failed with result 'exit-code'.

This is all I get when starting with systemctl. I only commented nlimitproc line in [email protected] file.

kernel:

Linux us2 2.6.32-042stab125.5 #1 SMP Tue Oct 17 12:48:22 MSK 2017 x86_64 x86_64 x86_64 GNU/Linux

If there is any relevant info I missed, just say and I will add more. Thanks in advance!


#2

This one /lib/systemd/system/[email protected] ?
Might help (but maybe you already did it…) : https://kiwix.infinitycommunicationsgateway.net/askubuntu.com_en_all_2017-06/A/question/747023/Systemd-fails-to-start-openvpn-in-lxd-managed-16-04-container.html


#3

i am letting you know how i succesfully got openvpn working… first i removed the quickVPN and all certs made from it, then ssh into server as root :

cd /tmp
wget http://swupdate.openvpn.org/as/openvpn-as-2.1.4-Debian8.amd_64.deb
sudo dpkg -i openvpn-as-2.1.4-Debian8.amd_64.deb

  • openvpn is the default username the last step after ibnstalling the vpn is to create a password

  • to do this use this command: sudo passwd openvpn

  • you can choose anything you want just make it hard to crack but easy to remember

  • then click either the link with your server ip and the port:943 or the one that says admin

  • the one that doesnt lists the different softwares you can use to easily incorporate your user config ovpn file it will be called client the mac and windows apps are straight foward you can just download the connect app listed for your os and then sighn into it and your golden. in linux its a little different tho you must have openvpn that will except a config file. ie import configuration option, once you choose that then select the clien.ovpn you dloaded and set it up as password login then put in opnvpn as username and then put in your specialy made password that you chose and watch the majic happen.

  • one note the default tcp port is 443 you need to login to the admin panel of the vpn on port :943 by puting /adminnext to the port number in the url line find the port settings and change the tcp port from 443 to something random but at leastr 5 digits to get the best return speed when connected. what that means is you will get almost have of your non vpn connection speed or more. at least thats wht i get and im usa my vps is in france i am a 250MBps ISP speed user at home toso all is good… I hope this helps many to come


#4

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.