Ombi v3 not updating

ombi

#1

Hello

I can’t seem to get Ombi to update, neither via the command nor the built in updater from Ombi.

My current version is 3.0.2328, yet the latest version of Ombi is 3.0.3111.

Can somebody help?

Thanks in advance, and thanks for a great product!


#2

Did you get this sorted? Need to update my version from a fresh install this week to enable newsletters.


#3

Yes, v2.5.4 fixed this issue for me. upgradeOmbi should now be working again.


#4

I ended up with a manual update, but jOhnwick is right - It works via the upgradeOmbi command again :slight_smile:

edit
It seems to default to the developer branch - Are you also seeing that?


#5

Yup, also got defaulted to the developer branch. Currently on 3.0.3282.


#6

I did a clean install this week and had 3.0.2328 installed. Will try the upgrade command and see!

Doesn’t work for me? -bash: upgradeOmbi: command not found

Sorry if this is dumb, absolute noob on Ubuntu


#7

I am facing the same issue, cannot update Ombi beyond the current v3.0.2328.
Running upgradeOmbi simply completes execution without any messages or errors. Running check for updates on the Ombi web portal returns no update available.

Ombi’s log under /opt/Ombi/logs only shows Internal Server Error with no additional error information: “[Error] StatusCode: InternalServerError, Reason: Internal Server Error”
syslog also does not contain any information related to this.

Also, as a part of trying to upgrade, I also ran the Quickbox updater from the dashboard, so I am now on QB v2.5.4

On a site note: @kill_bill login as root and execute the command “upgradeOmbi” without the quotes.


#8

@kill_bill use “sudo su” to be able to execute the upgradeOmbi command (Same as the other upgrade commands you’ll see under " Packages Commands ".

I guess v3.0.2328 is broken on quickbox - @j0hnwick did you upgrade from that version via the script, or manually?


#9

I get the same as @seer

Run the command, no errors. Start Ombi and still the same version.


#10

Updated QB to v2.5.4 through the dashboard: “run updater”. Then used upgradeOmbi to upgrade from v3.0.2328 to v3.0.3282.


#11

I saw that JMSolo might publish a new update to QB today, since radarr/sonarr/jackett now supports/requires Mono v5.10 - If you’re lucky, there has been some attention to the updater scripts as well… Otherwise I would just update it manually and be done with it.

What I did was rather simple.

Get the latest version here: https://github.com/tidusjar/Ombi/releases
Normally on QB linux.tar.gz

Make sure to unblock the archive file if you’re on windows (Something I always do, so not sure if it’s necessary here).
Stop Ombi service on QB dashboard
Make a backup of /opt/Ombi to for instance /home/username/Ombi_backup
Overwrite files from the zip archive on /opt/Ombi
Start the service on the dashboard

Should be everything - And the updater script should start to work again =)

Let me know if it works out =)


#12

Got it working after manual install/update.
Bear in mind that I had some issues after the manual install of Ombi causing my user not being able to log in. Turns out the error was that the Ombi.db sqlite database was locked (by itself though) giving an “SQLite Error 5: ‘database is locked’” error. I think it might be due to some CRON jobs running at the same time, as mentioned in some similar issues on their git repo.

Anyway, when trying again after 10-20 minutes it worked as expected, so if you encounter the same issue, have a little patience.


#13

Worked for me, thanks!


#14

i have 2.5.4 i enter SSH sudo su, upgradeOmbi and dont update :frowning:


#15

likewise, console doesnt even output anything, blank line shows up for about 5 seconds.

i had to manually upgrade ombi to latest.


#16

how did you update it manually? i did follow installation instructions and just break ombi


#17

just followed the instructions on the ombi install wiki. just make sure you change the permissions for the new files.


#18

the debian install or the other?


#19

i followed the manual install portion, except since we already have had it installed you really dont have to install the extra packages. so its bullet points 2-5. make sure to not download/extract as root.

  1. cd into that directory cd /opt/Ombi
  2. Download the latest linux.tar.gz @ https://github.com/tidusjar/Ombi/releases/latest for stable and use https://ci.appveyor.com/project/tidusjar/requestplex/branch/develop/artifacts for develop.
  3. With the newly downloaded linux.tar.gz file in /opt/Ombi run tar xzf linux.tar.gz
  4. In the /opt/Ombi directory make the Ombi file an executable: chmod +x Ombi