Ombi reverse proxy

ombi

#1

<Location /ombi>
Allow from 0.0.0.0
ProxyPass “http://localhost:5000/ombi” connectiontimeout=5 timeout=30 keepalive=on
ProxyPassReverse "http://localhost:5000/ombi"

RewriteEngine on
RewriteEngine on
RewriteRule ^/ombi$ https://MYSUBDOMAIN.quickbox.io/ombi/ [R=301,L]
RewriteCond %{HTTP_REFERER} "https://MYSUBDOMAIN.quickbox.io/ombi/"
RewriteCond %{REQUEST_URI} !^/ombi
RewriteRule ^(.*)$ /ombi$1 [R=301,L]

So I followed the steps I found on the forums for the reverse proxy config but I’m still unable to access ombi through my quickbox panel. I just get a gray screen that says loading.
The only way I’m able to access it is by going to http://IPADDRESS:5000/ombi

Is there anything wrong with my config?


#2

Is your server on a subdomain?


#3

Alright i got it working. Was quite annoying…

A copy of my ombi.conf (this is default) :
seedbox01:/etc/apache2/sites-enabled# cat ombi.conf
<Location /ombi>
ProxyPass http://localhost:5000/ombi
ProxyPassReverse http://localhost:5000/ombi
Require all granted

seedbox01:/etc/apache2/sites-enabled# pwd
/etc/apache2/sites-enabled

And then this was the big thing, even though it looks filled in, its not. You HAVE to manually type it “/ombi” :

ombiv1

I then simply restarted the ombi service from the dashboard and boom. Everything works.

Hope this helps all!