Ombi is asking for 'rutorrent' password


#1

I just set up Ombi but when anyone goes to the ombi url they get an authentication popup asking for ‘rutorrent’ credentials. How do I disable that popup so they can log into ombi with the credentials created in ombi? You can click cancel on the authentication popup and it lets you log into ombi. I checked the apache conf file for ombi and it does have the “Require all granted” added to it. I’m stumped and any suggestions or help would be greatly appreciated!


#2

You can edit the ombi.conf file located at /etc/apache2/sites-enabled/

Ensure it looks like the following:

<Location /ombi>
ProxyPass http://localhost:5000/ombi
ProxyPassReverse http://localhost:5000/ombi
Require all granted
</Location>

Then send a restart to apache with service apache2 restart. If you are still receiving the auth popup, try to clear your browser cache.


#3

Thanks for the reply! My ombi.conf file looks exactly like that and i’ve restarted apache a few times, cleared browser cache and data and tried multiple browsers but I still get the auth popup. I’ve tried modifying the ombi conf file a little just to make sure it is being used and it definitely affects things. Any other ideas on what could be causing the auth popup?


#4

Not really sure, the browser auth would only popup if the config has an expression for it to do so. I’ll have to think a bit on this one for a moment.


#5

I really appreciate the help! I’m no expert but everything i’ve read says that it should be working with the confg file set up like that. I just remembered that after I installed Ombi through the quickbox interface i had to replace the /Ombi files to get the newest version. Could that possibly have anything to do with it? I’m thinking not but for the sake of full disclosure I figured i better mention it. Im also running letsencrypt and routing traffic through cloudfare.


#6

Hmm, had you cleared the cache through Cloudflare, or are you just using DNS services? Something, somewhere, has got to be caching that.


#7

Admittedly im not exactly sure. I went to my cloudflare overview and it shows “caching level: standard”


#8

Is the little cloud next to your A Record orange?


#9

it’s orange


#10

Could you click it to make it grey and then clear all cache on Cloudflare?


#11

Just did it


#12

I tried multiple browsers and cleared all their cache and im still getting the popup. do i need to give it some more time to see if that worked?