Ombi 503 error after install

plexrequests
install

#1

Been trying to get Plex Request/Ombi working for a while but I can’t seem to get Ombi loading from the Dashboard

What I’ve tried so far

  • Uninstall/reinstall Plex Requests
  • Tried to open from IP address:3000/plexrequests (don’t have ability to SSH tunnel where I am currently at)
  • checked systemctl status and tried to restart (screenshot 1)
  • Update Quickbox to 2.4.8
  • Checked Plaza for help
  • Update repos as mentioned in PlexRequest 503 service unavailable
  • updated to Quickbox to 2.4.9 after updating repos.
  • Uninstall/reinstall Ombi (hey name changed!)
  • Attempt to connect again from port 3000/ombi
  • Checked service status (screenshot below)

To do (after posting)
Rebooted server and tried rebooting services again (I haven’t rebooted in 95 days, so maybe this is an issue?)

Still not able to get to Ombi to load, any help would be dope and if there’s anything I can do to help you guys (i know very little python but see that most of the github is python based), let me know.

Screenshot of systemctl status and restart prior to upgrading to 2.4.9

screenshot of systemctl status and restart after updating (no idea what ombi services would be called so taking a guess


#2

Yes, the project was forced to change their name to Ombi, due to Plex’s legal team. It’s only fitting we updated our side as well.

Since the name changed, have you tried:
IP address:port/ombi

That’s what it should be installed as (and also what the - - base setting is set for in your second screen): https://github.com/QuickBox/QB/blob/d19530cf9d5ab281dbd04ba8378febf47a04ab4e/packages/package/install/installpackage-ombi#L50

Although, your service looks like it’s not up. What happens when you try:
sudo systemctl status [email protected]


#3

here’s the result of that ( was already sudo su’d before typing the command)

It’s a little weird that sudo shows the service as non-existant but during it without shows that the service is started…


#4

Our repositories are currently in major overhaul and I am trying to decide the best approach to our next method of QuickBox delivery. With that being said, can you confirm if your QuickBox is running off our new ‘combined’ repo at QuickBox/QB and not QuickBox/QuickBox.

I’ll be posting up why this adjustment is happening in the next couple of days as I have been away for the weekend.

If you need to move to the new QuickBox/QB repo, you can do so by following this set of instructions here.

We made several adjustments and minor bug fixes on the combined repo and I can confirm that Ombi installs and properly displays service status on this new repo.

Service verification:


#5

im using the latest Quickbox/QB repo and when I install ombi through the dashboard or box cmd i get a 500 error trying to go to [ip or domain]/ombi. any further thoughts? I previously had plexrequests installed and it seems to have disappeared on its own after doing a update through the dashboard

edit: i finally noticed that plexrequests was still showing as installed in box. i uninstalled that and ombi and reinstalled ombi and it works thru the dashboard now.


#6

Sorry for the delay, I’ve been dealing with a broken PC and just now am getting above water.

I went through the instructions you mentioned in the post (not sure if they were the same as the ones in my opening post) and this came up.

Does this mean i’m on the right repo? Is there another way to check?


#7

Easiest way to tell is by your version. Are you on v2.4.9 or v2.5.0?

For that error in particular check this out:

wget -O /usr/local/bin/quickbox/system/updateQuickBox https://raw.githubusercontent.com/QuickBox/QB/master/packages/system/updateQuickBox &&
dos2unix $(find /usr/local/bin/quickbox -type f) && chmod +x $(find /usr/local/bin/quickbox -type f)
updateQuickBox

That command above should place you on the new repo along with updating your install.


#8

This is the result of the script.

I seem to be on 2.4.9 and I’m not able to upgrade further.


#9

Hello, I also can’t get Ombi loaded from the dashboard. It sounds very similar to what ohjk was experiencing. However, plexrequest seems to be completely removed from my box.

I’m on the newest repo (2.50) & Ombi status is showing active (green). However, I’m still getting “HTTP ERROR 500” when trying to load Ombi. Thanks for any help!


#10

PlexRequests is now Ombi. He had to change his name due to legalities with Plex. In honoring their agreement, we see it only fitting to parry up and do the same on our platform. It is now Ombi and will be installed via box install Ombi and box remove Ombi accordingly.

Are you on Debian by chance? Also, what is the output of systemctl status ombi


#11

ok, this gets weirder…

I just tried installing Nextcloud via box install and it says it can’t find the command. Even logging in as root and running it didn’t seem to work. I also can’t seem to uninstall Ombi from dashboard, it goes through uninstall motions but does not remove services or links from dashboard.

Did I hose my system somehow?

Edit: apparently the Quickbox folder does exist in etc but I can’t remove it using the first repo script from the wiki you gave me. Using the most recent one (wget), the directory it’s looking for doesn’t exist at all. (and I’m assuming it should be there to begin with)

Perhaps its time for a reinstall :’(


#12

No worries, no need for a reinstall!

Now I will edit… wanted to get this post to you before you killed too much of your time reinstalling. :slight_smile:

Do this, as it looks like you killed the /usr/local/bin/quickbox directory for the scripts.

local_packages=/etc/QuickBox/packages/
usrbin=/usr/local/bin/
cd ${usrbin}
cp -r ${local_packages}. ${usrbin}quickbox 
dos2unix $(find /usr/local/bin/quickbox -type f) && chmod +x $(find /usr/local/bin/quickbox -type f)
updateQuickBox

Then try to run the box commands once more.


#13

Thanks! Ill give it a shot later on in the day and update you on happens.


#14

Nope, I’m on Ubuntu 16.04. Here is the output as you requested:

systemctl status ombi
● ombi.service
Loaded: loaded (/etc/systemd/system/ombi.service; enabled; vendor preset: ena
Active: inactive (dead) since Sun 2017-04-16 02:10:46 CEST; 2 days ago
Process: 5170 ExecStop=/bin/kill -HUP (code=exited, status=0/SUCCESS)
Process: 5072 ExecStart=/usr/bin/screen -f -a -d -m -S ombi mono /opt/ombi/Omb
Main PID: 5077 (code=exited, status=0/SUCCESS)

Apr 16 02:10:40 ns527297.ip-192-99-10.net systemd[1]: Starting ombi.service…
Apr 16 02:10:40 ns527297.ip-192-99-10.net systemd[1]: Started ombi.service.

Thanks for your help!


#15

thought i posted but I guess I didnt. Been busy trying to get ready for a programming bootcamp!

This worked for me and now I can upgrade to 2.5.0. However, after reinstalling ombi, i still can’t get the dashboard to start the service nor can I start it manually. Systemctl status [email protected] shows the same as my previous screenshots.

In any case, I changed servers (decided to move to an SYS Canada server for about 5 bucks cheaper with a way better connection) and working through the hoarding.me setup and managed to get Ombi working there.

I have the old server if you need me to get anything for troubleshooting purposes otherwise case is closed :slight_smile:


#16

I resolved this in a PM for @j0hnwick by running our builtin upgradeOmbi command. It backs up the database and performs the necessary updates. Should work if this is an ongoing issue. I am going to set some time aside soon to troubleshoot why this is randomly happening on the initial install.

This may additionally be a left over result from previous versions wherein we had the service listed as PlexRequest, due to their name change to Ombi in the new versions it may had caused this complication for those upgrading.


#17

I had an issue with installing Ombi. I had previously had Plexrequests setup and working before the name change.

Plexrequests was no longer on my Quickbox page for some reason, so I went and installed Ombi. It said it was installed properly but when I went to URL.com/ombi it was 404 error.

I tried uninstalling, installing again - same issue. I tried running box remove plexrequests - It said it removed it.

Tried installing Ombi again, same problem - I then updated Quickbox to the latest v2.5.1 and tried again, no progress.

When I ran “systemctl status [email protected]” it was alive and working (even though I had “uninstalled it”).

I think I did “systemctl stop [email protected]” and that sort of fixed it for me.

Right now URL.com/Ombi works
URL.com/plexrequests receives 404.

Yet if I run “systemctl status [email protected]” I get the error:

[email protected]
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

And if I run “systemctl status [email protected]” I get the error:

systemctl status [email protected][email protected]
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

Strange things happen when names get changed! My Ombi does work properly, I configured it and have successfully had imports from Couchpotato. I access it through URL.com/Ombi.

:laughing:


#18

Ahh, my Ombi has stopped working now.

Both plexrequests and ombi are showing as not installed or running when I type them with @USERNAME on the end of systemctl status.

But if I type “systemctl status ombi” without @USERNAME I get:

 ombi.service
   Loaded: loaded (/etc/systemd/system/ombi.service; enabled; vendor preset: ena
   Active: active (running) since Wed 2017-04-26 02:26:45 UTC; 2 days ago
 Main PID: 21657 (screen)
   CGroup: /system.slice/ombi.service
           ├─21657 /usr/bin/SCREEN -f -a -d -m -S ombi mono /opt/ombi/Ombi.exe -
           └─21658 mono /opt/ombi/Ombi.exe -p 3000 --base ombi

And for Plexrequests:

plexrequests.service
   Loaded: loaded (/etc/systemd/system/plexrequests.service; enabled; vendor pre
   Active: failed (Result: exit-code) since Wed 2017-04-26 02:26:23 UTC; 2 days
 Main PID: 736 (code=exited, status=1/FAILURE)

I cannot seem to uninstall and re-install them as my user, any idea how this can be fixed? I’m on the latest Quickbox.

Thanks for reading.

EDIT: After doing systemctl restart ombi, Ombi now loads again. I guess it isn’t necessary to have Ombi installed under my user?

Are there any scripts that will automatically restart a plugin once it shows failed or inactive?


#19

It should restart automagically. Also, PlexRequests is Ombi. If you’re coming off from updating an older version of QuickBox, it may be necessary to run upgradeOmbi to backup and resert the database to make use of the new Ombi.


#20

Strangely Ombi seems to not be installed under my user and still works. I ran box upgrade ombi and it is still the same.

Mock5:/home/wut# systemctl status [email protected][email protected]
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
Mock5:/home/wut# systemctl status ombi
● ombi.service
   Loaded: loaded (/etc/systemd/system/ombi.service; enabled; vendor preset: ena
   Active: active (running) since Fri 2017-04-28 18:50:55 UTC; 3 days ago
  Process: 4334 ExecStop=/bin/kill -HUP (code=exited, status=0/SUCCESS)
  Process: 4338 ExecStart=/usr/bin/screen -f -a -d -m -S ombi mono /opt/ombi/Omb
 Main PID: 4342 (screen)
   CGroup: /system.slice/ombi.service
           ├─4342 /usr/bin/SCREEN -f -a -d -m -S ombi mono /opt/ombi/Ombi.exe -p
           └─4343 mono /opt/ombi/Ombi.exe -p 3000 --base ombi

Apr 28 18:50:55 Mock5 systemd[1]: ombi.service: Failed with result 'exit-code'.
Apr 28 18:50:55 Mock5 systemd[1]: Starting ombi.service...
Apr 28 18:50:55 Mock5 systemd[1]: Started ombi.service.