Not getting plex working on Hetzner

install
plex

#1

Heyho,

Since I’ve been spending the past 3 days trying to get Plex, and preferable with Quickbox, to work on a Hetzner server I have no clue what I can do anymore to get it to work, including almost every solution I could find on here. Note I’ve some experience with setting up dedi servers and plex but not plex on a dedi server, so I thought this would be a nice experience.

My main issue with getting Plex up is that I somehow eventually get it set up, but either I can’t get the connection working outside of the tunnel/proxy or I get an indirect server which makes plex “work” on the web version but not on the mobile apps.

I’ve been wondering to actually reset the server, for like the 8th time, and pay for either an install, tuning or even both as long as Plex would actually work that way.

So my question is does someone have any tips that I could still try, or can someone assure me that if I pay for either the install/tuner service my plex would somehow work afterwards?


#2

Hi,

Have you checked the “remote access” status?

PLEX > Settings > Server > Remote Access
You must have a GREEN check mark if network mapping is working


#3

Yup it’s showing up as “Fully accessible outside your network” using the ssh tunnel and a green mark next to it, but the moment I use plex.tv it shows “The selected server is unreachable. Make sure it’s running, double check your network, and try again.”


#4

Try to logout from plex on every device and login again. I’ve faced the exact same issue few weeks ago.


#5

Thanks for the ideas!

Tried logging off using either the logout button or using the device window. Restarting Plex or rebooting afterwards. Issue still persists :confused:


#6

Perhaps Hetzner filter some port numbers like 34000…
When you ssh tunnel to your box it’s ok (mapping seem working), but from outside if port is blocked by hetzner network you can’t reach your plex server.


#7

Checking my own Plex configuration, I’m remebering I’ve disabled SSL (Settings>server>Network).


#8

okay after a fresh install I tried turning the secured connection + GDM off. I have Plex working now in the proxy + tunnel, any other way just doesn’t seem to work (using any mobile apps or plex.tv or direct ip:port link)


#9

Conclusion: I’m a retard

Tip to other people that are switching to an remote server that used to have plex run local: remove the forwarding of port 32400 from your router… (Yes I feel retarded)

I have everything working except from my apple tv for some reason, but will look at tomorrow.