Not all disk space found


#1

Hello every body, i have a little problem with my new server.
I already installed quickbox script thousand of times :slight_smile: but now, i have a little problem :frowning:

I explain : i have 2x3TB
I followed an tutorial, (http://zoneadmin.fr/forum/threads/test-comparatif-une-seedbox-chez-hetzner.4018/) on which it’s said that i have to specify “raid 0” to get 1x6Tb instead 2x3.

I did this, and then i launched the Quickbox script : it was write 5800go (perfect ?)

But, after a successful installation : here you can see, only 1Tb is found by the widget

So, i tried many things : lsblk

which seems to be a little bit strange :frowning:

And then /etc/fstab

in this, at first i had /dev/md/3 instead md3, i changed, but nothing changed on my server.

I don’t think what is the problem …

I also tried this tutorial : Adding new disk to user directory, without success

Any help would be appreciated :slight_smile:

Thanks !


#2

After you follow that guide, you would essentially have to then, tweak the Disk widget to play nice with the settings. For instance:

On lines 68-76 of the disk_datah.php widget code, you’ll see variables marked for the location to use for the mount to read from.

  //hard disk
  $dftotal = number_format(round(@disk_total_space($location)/(1024*1024*1024),3)); //Total
  $dffree = number_format(round(@disk_free_space($location)/(1024*1024*1024),3)); //Available
  $dfused = number_format(round(@disk_total_space($location)/(1024*1024*1024),3)-round(@disk_free_space($location)/(1024*1024*1024),3)); //used
  //hard disk for percentages
  $dptotal = round(@disk_total_space($location)/(1024*1024*1024),3); //Total
  $dpfree = round(@disk_free_space($location)/(1024*1024*1024),3); //Available
  $dpused = $dptotal-$dpfree; //used
  $perused = (floatval($dptotal)!=0)?round($dpused/$dptotal*100,2):0;

Like this @disk_total_space($location). This value is pulled from line #38, which is $location = "/home";. You will need to change this to $location = "/home/seedkerz/torrents";. Be sure to modify the disk_datah.php plugin. You could additionally create a carbon copy of this widget (which I strongly advise to avoid overwriting on updates). Just do …

cp /srv/rutorrent/home/widgets/disk_datah.php /srv/rutorrent/home/widgets/disk_datac.php

Then make the adjustments to the newly copied/created disk_datac.php as explained above.

Next, you will need to open /srv/rutorrent/home/inc/panel.header.php and make an adjustment to the ajax settings at line #288-294. Make sure it looks like the following:

  function diskstats() {
    $.ajax({url: "widgets/disk_datac.php", cache:false, success: function (result) {
      $('#disk_data').html(result);
      setTimeout(function(){diskstats()}, 15000);
    }});
  }
  diskstats();

We currently only support /(root) and /home mounts at this time, I am trying to work out a better solution for those with crazy drive setups… but since everyone has a different approach to naming mounts etc, it makes things a bit more complicated.


#3

I have no idea why, i can’t follow completly the guide…
I can’t mount anything, do you think my lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL seems OK ?

The problem is, why i don’t this this in the widget, because i don’t know the differene between my sdb (that i think is show by the widget) and the sdb4 ?

And after, why i can’t format my sda4 , or mount it ?
Like i said; i can’t finish the guide Adding new disk to user directory … I don’t know why, i can’t mount all my partition, and if i understand well,i don’t need to create partition .

My problem is why the widget is able to see sdb4 and not sda4 ?
I though sda4 is already mounted …


#4

Seems fair enough…

Is this a local home server, or one provided by a provider such as Hetzner. You’re essentially asking for a custom scope of work, which I don’t have time for at the moment. If this is a provider, I would suggest a rebuild as I cannot possibly say why you’re not able to mount the drives according to that guide.

Is there a particular error that is occurring? A little more info other than “It won’t mount” would go a long ways. Did you change the partitions after your original post, as I am slightly confused why the naming of the mounts are different here as opposed to the above.


#5

In fact, i found the problem :slightly_smiling_face:
Like you said it before, it is a hetzner’s server. I didn’t know this provider , before i was on Ikoula.

At the beginning of the installation, we have a set up “.conf”, and we need to specify that we will use raid0.
But that’s not at all, we also need to specify that “/” will get all the free space and not “/home”.

That’s kinda weird before, like you said , the widget is looking for $location = /home/ , but, that’s the trick :slight_smile:

So, to conclude, It is not a fault on the side of your program.

I apologize for the inconvenience, and from what I could see I also find that hetzner servers are particularly “strange”.
I thank you, you and the team for the speed of your response as well as the fabulous work you do. I appreciate this script enormously, and I recommend it to my friends.
Keep going !