No HTTPS even after setting up LetsEncrypt


#1

I set up lets encrypt by following the instructions in the wiki but the page is still showing HTTPS errors.

This is from Chrome

“Valid Certificate
The connection to this site is using a valid, trusted server certificate.
View certificate
Secure Connection
The connection to this site is encrypted and authenticated using a strong protocol (TLS 1.2), a strong key exchange (ECDHE_RSA with P-256), and a strong cipher (AES_128_GCM).
Active content with certificate errors
You have recently allowed content loaded with certificate errors (such as scripts or iframes) to run on this site.
Content with certificate errors
This site includes resources that were loaded with certificate errors.”


#2

Hey bud,

is this the quickbox dashboard you’re loading?

have you already tried:
sudo service apache2 restart

This line:

You have recently allowed content loaded with certificate errors (such as scripts or iframes) to run on this site.

Looks like the trouble, is your domain pointed directly to the quickbox IP and you’re accessing via https://my.domain.net ?


#3

Yes, but issue exists on rutorrent too.

Yes

I pointed the domain directly to the ip using an A record.
I’m accessing it via https://my.domain.com


#4

Have you performed the final sed command followed by flushing your browsers cache?

sed -i "s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g" /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart

#5

I performed the last command but hadn’t flushed my browser.
Flushing my browser fixed the issue.

Thanks a bunch.


#6

Now matter how many times I see clearing the cache fixes the issue, I still always forget!

As a habit now, when I’m testing changes to a website I use private browsing to load a new copy :slight_smile:

Glad you got it sorted :slight_smile: