No disk information in rutorrent and quickbox


#1

Hello,

Setup is dedicated machine with Ubuntu 16.04 64bit and 2 HDDs in RAID 0.

I’ve set the destination folder during installation to /home, looking at settings of the users it also sets correct top directory for plugin to use.


#2

I assume this may fix your issue

apt-get install -y linux-image-extra-virtual
service quota stop
quotaoff -a
quotacheck -auMF vfsv1
quotaon -uv /home
service quota start

For the double diskspace plugin you can disable the plugin named diskspace within your ruTorrent > Plugins tab. Leave the diskspaceh plugin enabled


#3

When sending command “quotaon -uv /home” I get:

quotaon: Mountpoint (or device) /home not found or has no quota enabled.

I made quotas with “setdisk”.

Mountpoint /home exists

Filesystem Size Used Avail Use% Mounted on
udev 7.8G 0 7.8G 0% /dev
tmpfs 1.6G 73M 1.5G 5% /run
/dev/md2 44G 3.0G 39G 8% /
tmpfs 7.8G 0 7.8G 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 7.8G 0 7.8G 0% /sys/fs/cgroup
/dev/md1 488M 97M 366M 21% /boot
/dev/md3 5.4T 81G 5.1T 2% /home
tmpfs 1.6G 0 1.6G 0% /run/user/1000


#4

Are you using Kimsufi or Hetzner?

This implies that your fstab is not set properly as it doesn’t have a disk to use with quota. What are the results of cat /etc/fstab?


#5

Yes, I’m using Hetzner

Result of cat /etc/fstab:

proc /proc proc defaults 0 0
/dev/md/0 none swap sw 0 0
/dev/md/1 /boot ext3 defaults 0 0
/dev/md/2 / ext4 defaults 0 0
/dev/md/3 /home ext4 defaults 0 0


#6

Ok, now change the following:

proc /proc proc defaults 0 0
/dev/md/0 none swap sw 0 0
/dev/md/1 /boot ext3 defaults 0 0
/dev/md/2 / ext4 defaults 0 0
/dev/md/3 /home ext4 defaults 0 0

to this:

proc /proc proc defaults 0 0
/dev/md/0 none swap sw 0 0
/dev/md/1 /boot ext3 defaults 0 0
/dev/md/2 / ext4 defaults 0 0
/dev/md/3 /home ext4 usrquota,errors=remount-ro 0 0

Now run:

service quota stop
quotaoff -a
quotacheck -auMF vfsv1
quotaon -uv /home
service quota start

This should patch you up. This is a known issue with Hetzner as they use “defaults” rather than “errors=remount-ro”, which is what the script looks for on install. I plan on making this process smarter… I just need to get smarter first :stuck_out_tongue_winking_eye:


#7

I think you are a genius already, it works now in quickbox :smiley:

It still doesn’t work in RuTorrent, both are blank, if I disable only “diskspace” they both disapear.

It works in one place, so thats more than enough for me, thanks a lot for your time and help.

Its a great project.

Regards