New Installation ... rtorrent Failed to Add torrent. Can't retrieve URL

rutorrent

#1

Brand New Installation

go to rutorrent. Add Torrent

[27.05.2017 02:19:34] https://privatetorrentsite.com/torrents.php?action=download&id=1&authkey=AUTHKEY&torrent_pass=TORRENTPASS - Failed to add torrent. Can’t retrieve URL.

It works fine on my home machine. Also, if I setup autodl-irssi, torrents for that same private torrent site can be added. But if I manually add torrents through the rutorrent interface, it gives me that error.

edit: is it possible to downgrade quickbox?

I have been debugging this with a couple other people and can’t seem to figure out the issue.

Would like to downgrade quickbox to what i was using before to see if that helps.

edit 2: narrowed it down to rutorrent issue, not rtorrent (can add the URL in rtorrent command line)

edit 3: Seems to be a Linux box issue? I went through the process to install the seedbox manually (rtorrent/rutorrent and all the libraries), and I am still getting the issue. So not sure what is going on here.

edit 4: Have narrowed it down to the exec command in rutorrent/php/Snoopy.class.inc Line 504

Exec command returns a curl error 56. But if I run the command manually, it runs fine?


#2

Just want to share what the solution was.

Apparently, ruTorrent updated the rutorrent/php/Snoopy.class.inc and it was causing issues with not only this, but with loading RSS feeds (which I just ran into too)

I found a post about RSS feeds not working and them pinpointing it to the Snoopy class.

So people mentioned to use an older version of Snoopy to get it working.

And that fixed it for me, both the RSS and the Add Torrent by URL

Edit: To be specific, I used the Snoopy.class.inc file here:

But ruTorrent also reverted the change that was causing this. So the newest version as of this date now works:


#3

Thank you for posting your solution! :heart: