Multi-user issues


#1

Hello, I am very happy with this script for myself but I recently tried to add my friend to my box as another user and he is unable to connect via sFTP. Filezilla returns this error “Error: Received unexpected end-of-file from SFTP server \ Error: Could not connect to server”. installed the latest version of the script as of yesterday on ubuntu server server 16.04. I also had to chown his autodl irssi config file for him to be able to write to it from rutorrent. Thank you

edit: I forgot to mention that he is able to connect via regular plain text FTP and he can also login via SSH, just can’t login to sFTP


#2

are you trying to log in ftp with filezilla or a ftp client?

also set as ftp instead rather than sftp

filezilla works well as ftp


#3

I am trying to login sftp via filezilla and it is failing. I am able to login via regular ftp with filezilla but I would prefer the traffic to be encrypted. I have also tried with other ftp clients like cyberduck and cuteftp and I am still unable to login via sftp with his account


#4

because sftp is not enabled in the script.


#5

it’s enabled for my master user, I can login with my master account and transfer via sftp. So you’re saying for any additional users that I add they aren’t also able to use sftp? only ftp


#6

Your master user, the one used on script install should have SFTP without issue. If you would like your friends to have SFTP, you will need to add them to sudoers. The reason being the script implements limited shell for it’s bash environment. You can enable SFTP via /etc/lshell.conf

Then change the line:

sftp            : 0

to

sftp            : 1

:warning: Heads Up!

This can lead to users easily breaking out of their directories. I can implement a fix in the next couple of days that addresses this and offers better chroot lists with lshell. TLS is normally enough to encrypt a connection, but it is understandable some want higher grade encryption.


#8

awesome! thank you very much JMSolo and dtech for your responses. Everything works perfectly now with the sftp. I’m not too worried with him getting out of his directory as he is a personal friend but thank you for the warning


#9

Hey, do we finaly have any solution to enable sftp for all user and keep them chroot in their directory?

Thx


#10

We do not, however, FTP with auth TLS is still a secure option.


#11

Oh thx, i had miss that possibility