Missing rtorrent.lock file ; rtorrent not running

Hi Team,

Having a issue with loading rutorrent. The rtorrent not able to connect as per attached pic.

The rtorrent.lock file is missing. Have tried systemctl commands to stop rtorrent, restart, reboot server. No joy with multiple attempts. giving up now, requesting advice what else to be done ?

Is it possible to reset settings ? the torrent files and data should not be disturbed.


The screen running rtorrent is empty !!
The port settings on rtorrent.rc and apache2- default-ssl config file is same.

Hey there @dorm!

What is the output of systemctl status [email protected]

[email protected] - rTorrent
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: active (running) since Sat 2020-09-12 17:53:36 IST; 14h ago
Process: 28923 ExecStop=/usr/bin/killall -w -s 2 /usr/bin/rtorrent (code=exited, status=1/FAILURE)
Process: 28928 ExecStart=/usr/bin/screen -d -m -fa -S rtorrent /usr/bin/rtorrent (code=exited, status=0/SUCCESS)
Process: 28925 ExecStartPre=/bin/rm -f /home/%I/.sessions/rtorrent.lock (code=exited, status=0/SUCCESS)
Main PID: 1253
CGroup: /system.slice/system-rtorrent.slice/[email protected]
├─1253 /usr/bin/SCREEN -d -m -fa -S rtorrent /usr/bin/rtorrent
└─1322 /bin/bash

Shows running but still no joy on rutorrent ; the rtorrent.lock is still missing.

Further, tried to run rtorrent with link to .rtorrent.rc file but had following error :

usr/bin/rtorrent -o import=/desktop1/.rtorrent.rc
rtorrent: Failed to parse command line option: Could not open option file: /desktop1/.rtorrent.rc

The .rtorrent.rc file exists with correct permissions.

Further, tried to run rtorrent command only ; the address could not be used , checked and found that port is not in use :

alias findport=‘sudo netstat -tulpn | egrep --color=auto’

UPDATE :

RTORRENT WORKING !!

Changed localhost to 127.0.0.1 in .rtorrent.rc file and rtorrent fired up.

Changes to .rtorrent.rc https://prntscr.com/ugdt9t

Unfortunately , the rutorrent still has no connection to rtorrent https://prntscr.com/ugdtdw

UPDATE : WORKING NOW ; had to change localhost to 127.0.0.1 in user/config.php under rutorrent. @JMSolo - Any idea what could be reason for using 127.0.0.1 instead of localhost.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.