Manage couchpotato-sickrage from Android Device

sickrage
couchpotato
android

#1

Hello,

Before I used NZBManager for manage sickrage and couchpotato from my Android device, but since the last update and the reverse proxy, the app doesn’t work…
Does anyone know the configuration to be? Because with NZB +, I can make it work, but I prefer NZBManager … And the configuration page between the two is the same, but it does not work on NZBManager …


#2

You should still be able to access it via the ports on standard (non-https) connections.

SickRage port    = 8081
Couchpotato port = 5050

#3

I know, but that doesn’t work…
I have a message: "Failed to connect…"
My configuration:

Heberger image
And with this configuration, I have this message:

GET “…” - Failed to connect to myip.com

I tried to connect with port 443 too and reverse proxy, so in my hostname, I put: myip.com/sickrage, but that doesn’t work…

Thanks for your help


#4

This tells me that whatever NZBManager is, it is something wrong with it’s methods and not your system. If you can get it to work with NZB+ then this adds validity to the claim. I tried looking for NZBManager and cannot find this app. I do know that NZB+ is an official app. Is NZBManager a third-party (non google play) application?

###Update:

After looking closer into this. The object string exception that occurs means that the proxies auth function for connecting is what’s blocking the apps to connect.

Open up /etc/apache2/sites-enabled/couchpotato.conf and comment out the auth lines in the configuration. It will look like this:

<Location /couchpotato>
ProxyPass http://localhost:5050/couchpotato
ProxyPassReverse http://localhost:5050/couchpotato
#AuthType Digest
#AuthName "rutorrent"
#AuthUserFile '/etc/htpasswd'
#Require user YOURUSERNAME
</Location>

Then restart apache with service apache2 restart and try to connect once more. Follow this same method for the sickrage.conf file.


#5

I tried to play with this the other day: https://play.google.com/store/apps/details?id=com.mgaetan89.showsrage

Thanks to this thread I’ll have another go at it :slight_smile:

Thanks everybody!


#6

Trying that app now @valkyre14 and it does not want to connect at all. The NZB+ connects to both /sickrage and /couchpotato without issue. This one can’t seem to find the api via https://SERVER/sickrage/api/LONGASSAPISTRING, which you can put that in for your sickrage instance and it will show you the API variables… just not sure why ShowsRage doesn’t “get it”

I’ll keep testing it.


#7

Not exactly true, remote access has been disabled via ports. Everything is bound to localhost now and exposed via remote proxy


#8

Well, I don’t use any of this stuff on mobile. However, I did also post the proper means for connecting :stuck_out_tongue: after testing it.

@liara, have you tested ShowsRage and managed to connect. I am wondering if that app just doesn’t play well with proxies.

It’s like authentication is being required anyhow on deeper links within the /sickrage… thus this app and some others will not be able to connect to the api. Not sure if there is a way around it. The NBZ+ seems to be smart enough to figure all that out on it’s own.


#9

I test your instruction: modify > /etc/apache2/sites-enabled/couchpotato.conf, but it’s still not working, but I can access to my couchpotato without https, with the port 80.

I don^t know why we can’t find NZBManager in the play store, but it’s in the “Web Play Store”: https://play.google.com/store/apps/details?id=nl.timkatgert.nzbmanager&hl=fr


#10

With NZB+ I was able to connect via https without issue.

Hostname is your IP or domain.name
Leave port field empty
URL extension is /couchpotato/
API Key is what is found within Settings > General of CP
Use SSL is checked
Enable Authentication and insert your username and password.


@dzouda, unfortunately that app is not compatible with my device and therefore I cannot test it.

###Update

@valkyre14, for the ShowsRage app… change your /etc/apache2/sites-enabled/sickrage.conf to this:

<Location /sickrage>
  ProxyPass http://localhost:8081/sickrage
  ProxyPassReverse http://localhost:8081/sickrage
  Satisfy Any
  Allow from all
  #AuthType Digest
  #AuthName "rutorrent"
  #AuthUserFile '/etc/htpasswd'
  #Require user quickbox
</Location>

<Location /sickrage/api>
  Satisfy Any
  Allow from all
</Location>

And within the settings for the Server:
Use HTTPS? []
Self-signed certificate? Only check if you don’t have Let’s Encrypt and a domain.name
Hostname = your serverip or domain.name
Port Number = leave blank
Path = sickrage/api
API Key = YourAPIKey
Use basic auth? [
]
Username/Password

Then Test should be successful and now you’re cooking with hot water.


#11

that’s brilliant!

I didn’t realise how messy reverse proxies made things!

I’l try this tonight when I get in


#12

Thanks JMSolo, now it’s working for me.

I use now for interessed people CouchPotato Mobile and ShowRage.

I have changed my /etc/apache2/sites-enabled/sickrage.conf like you said and the same things for couchpotato, but don’t forget:

  Satisfy Any
  Allow from all

Or Couchpotato Mobile going ask you at each start your login and password.

But with this method, you MUST have a login page for Couchpotato and Sickrage, because you will not be asked to identify yourself for enter to the page.