LetsEncrypt Problem

letsencrypt

#1

Hi,

I followed the LetsEncrypt guide to the letter.
https://plaza.quickbox.io/t/install-lets-encrypt-on-your-seedbox/99?source_topic_id=1465
The installation went through fine but I was not given a choice of what apache file to pick as a result now apache seems l messed up, When I load the home page the apache page come up instead of the QuickBox page, all the other pages work fine.
Is there anyway I can repair it.
Any help would be much appreciated.


Let's encrypt installation delete Quickbox Apache2 config
Let's encrypt installation delete Quickbox Apache2 config
#2

Just for confirmation, did you perform the final sed command?

sed -i "s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g" /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart

#3

What probably happened is LE made its default conf and it’s loading it before the seedbox confs causing it to conflict.

A bit of editing is required. Grab the certificate locations from the file /etc/apache2/sites-enabled/000-le-default.conf (or similar). This is likely something to the effect of:

        SSLCertificateFile /etc/letsencrypt/live/your_domain/cert.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/your_domain/privkey.pem

and paste/overwrite the values for the same lines in the file /etc/apache2/sites-enabled/default-ssl.conf

Remove 000-le-default.conf and reload the apache config with service apache2 reload. Everything should be working after this

Edit: I suppose the sed command should fix things as well :wink:


#4

Perfect, thanks guys.
Cheers
Mark