LetEncrypt error validation data

letsencrypt
ubuntu

#1

Hi Quickbox Party People,

I want to install a ssl certificate on my server. But I cant get it to work. I hope someone here can point me to the right direction. I bought a valid domain via namecheap.com and set up an account with cloudflare. I changed the nameserver at namecheap to the cloudflare ones and pointed the domain to the IP of the seedbox. I can access the seedbox via the domain.

However when I follow the wiki entry I get the following error message:

  • The following errors were reported by the server:

    Domain: jack.club
    Type: connection
    Detail: Fetching
    https://163.xxx.xxx.8/.well-known/acme-challenge/hhHcO4xYpyo1aGSuJxjdM5ftbNXdAoVVjwF4PDb39F4:
    Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

What is the problem here?
btw I get the same error when i try it using the box install command instead of the wiki. The difference is that when I use the box command my apache2 ssl def is always messed up and I need to change it back to the default entries.

Thanks for you help!


#2

make sure the CloudFlare “cloud” us grey when running the SSL script
46


#3

Hi bate,

thanks for your quick response.
I changed it to the grey icon

grafik

Now when I follow the wiki instructions I get to a the point where I am prompted which configuration to use:
grafik

But there is no 000-default.conf as instructed?! Which one do I choose?

I also tried to run the box command but still I get the fetching error as I described before.

Thanks!


#4

No. If you followed the wiki instruction all you had to do was run
box install letsencrypt

12

Try it out :slight_smile:


#5

thanks for your input bate. you made my day!
At first I had to remove my certificate in the path /root/.acme.sh.
When I run the code again it worked.

Thanks again for your valuable input!


#6

You’re welcome.
The installation bugs if you first run the old install instruction and later on try to run the box install method. You will need to remove any old certs in that case.

Good job :slight_smile:


#7

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.