Jackett - Page cannot be found

jackett

#1

I recently did a fresh install of QB.

box install jackett > selected EXT for external IP access. When I click on Jackett through the dashboard it redirects me to: https://domain.com/jackett/Admin/Dashboard and just says:
404 This domain.com page can’t be found
No webpage was found for the web address

Not sure what is going on, I’ve tried uninstalling and re-installing multiple times.

If I run systemctl status [email protected]:

[email protected] - jackett
   Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-07-07 20:37:53 EDT; 3min 48s ago
 Main PID: 4568 (mono)
   CGroup: /system.slice/system-jackett.slice/[email protected]
           └─4568 /usr/bin/mono /home/domain/Jackett/JackettConsole.exe --NoRestart

Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/ultrahdclub.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/utorrents.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/waffles.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/worldofp2p.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/xtremezone.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/zamundanet.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/zelkaorg.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Loading Cardigann definition /home/user/Jackett/Definitions/ztracker.yml
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Adding aggregate indexer
Jul 07 20:37:57 domain.com mono[4568]: 07-07 20:37:57 Info Starting web server at http://*:9117/

Any idea?


#2

Exactly the same problem for me… Anyone ? :slight_smile:


#3

Attempting to troubleshoot this issue now. Since I did your install today @pinedours75, I sent you a PM. Pretty sure I know what the problem is after re-checking the updated package install for Jackett.


#4

I found a temporary work around by accessing http://domain.com:9117/Admin/Dashboard instead
Please let me know of the resolution as well. Cheers!


#5

to fix correct the BasePathOverride in the user directory

cat /home//.config/Jackett/ServerConfig.json
"BasePathOverride": “jackett”,

looks like the installer isn’t running this correctly from install script:
sed -i “s/“BasePathOverride.*/“BasePathOverride”: “/jackett”/g” /home/”${username}"/.config/Jackett/ServerConfig.json


#6

It’s more to do with the IP not getting set. I am building a base template to resolve this issue:

Here…

and here…

Testing this on Development and it’s resolved. I am going to play with it a bit more.

Long day, I meant to add more. The template will remove the need for those sed commands.


#7

Thanks for all the work you’ve been doing on this project! It’s been super useful and has really saved me HOURS of setup time.

I was just wondering if there’s a way to fix this using what you’ve done in the development branch on a server in production? (sorry - I’m pretty new to git and am learning linux as I go :slight_smile:)

The other solution by @TehShocker is working but it takes a stone age to load the page for some reason, while the workaround from @RugerX works quickly but doesn’t have SSL


#8

I merged a potential fix for this, this morning. I have tested it over and over and can confirm it to be working. You can update either from your dashboard, or by way of the command (as root user) box upgrade.

Here’s the commit where I’ve added a template to be fired rather than waiting on the service to build the config on startup and shutdown.


#9

Brilliant, thanks - I’ve just tried this on my box and it seems to have fixed it


Jackett service unavalible
#10

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.