Jackett download issue

When I try to select a search result to download from a tracker, via Jackett, Jackett gives me a localhost URL for download. Since I am accessing the web page remotely, it fails. Not sure what to do in this situation.

I can confirm that I see the same issue.
Also API calls fail (made a mistake previously).

Seems like the proxy is somehow messing up

running a2dissite jackett.conf, accessing jackett by manually typing port, fixes this. Definitely is an issue with /etc/apache2/sites-enabled/jackett.conf. I’m not good with apache (I’m an nginx person), so not sure how to remedy it.

To fix this (actually, fix), sudo nano /etc/apache2/sites-enabled/jackett.conf

ProxyPass http://example.com:9117/jackett
ProxyPassReverse http://localhost:9117/jackett

Change ProxyPass to IP/Domain name. Save file, restart apache with: sudo systemctl restart apache2.service

This will be fixed for new installs with this pull request: https://github.com/QuickBox/QB/pull/40

A simple one-liner for current users would be:
ip_ext=$(wget -qO- http://ipecho.net/plain) && ip_int="localhost" && sudo sed -i "s~ProxyPass http://${ip_int}:9117/jackett~ProxyPass http://${ip_ext}:9117/jackett~" /etc/apache2/sites-enabled/jackett.conf

Weird…I applied this fix, restarted apache successfully, but now Jackett won’t load at all. I keep getting “503 Service Unavailable” on “https://domain.com/jackett/Admin/Dashboard”.

I had to change the ProxyPass back to ‘localhost’ instead of ‘IP/domain’ for it to work again.

Edit: Nevermind, forgot to enable external access. Now it works fine.

Is there a way for me to custom select a torrent from within Jackett and send directly to Sonarr? The download buttom just downloads the file to my PC.

Had me sweating there until I saw the edit xD Glad you got it working. Just for the record, when new users install jackett and enable external IP, I already have it scripted to enable Jacket external option.

No, that’s not a feature of Jackett at the moment. You can add jackett entries into Sonarr Indexer settings, then search from within Sonarr though :slight_smile: