Issues with what looks like letstencrypt?

nginx
cdn
cloudflare
ubuntu
plex

#1

So about a month ago I paid for the guru services to get the cloudflare routing for plex done and its worked great.

Recently, as in the last day the domain plex.domain.com has gone from showing secure connection to switching to insecure connection and when you try to open my server on any of the apps it either says its not a secure connection or the server isn’t accessible.

If I manually go to plex.domain.com and log in I can see my library just fine, so I know that the actual server is still up, its just when you try to hit it via any of the apps when problems start to show up

My first thought was maybe my cert just expired and didn’t auto renew so I ran the command

“sudo letsencrypt certonly -a webroot --webroot-path=/var/www/html -d plex.yourdomain.com” but I would then get a message saying that I already have an active certificate for that domain and that it wasn’t’ even close to expiring and would give me a option to renew it which I have not yet done.

Not really sure on how to even start on trouble shooting it from here.


#2

Could you run the following:

"/root/.acme.sh"/acme.sh --cron --home "/root/.acme.sh"

Also, what does your crontab look like? You can see/edit it with crontab -e


I am additionally noticing now that you have the tag nginx in your subject. This is an important detail. Are you running plex via Nginx as per our Wiki? If so, you cannot auto-renew, nor manually renew for that matter, unless you do service nginx stop, then try the renew.


#3

this happened to me as well had to rebuild everything then realized if i just moved the plex.conf out of the dir then ran the command then moved it back it would be the same. might also have to remove the old certs


#4

Screen cap of when I run that command

Also screen cap of Crontab

I tagged nginx because I was under the impression that my failover IP was bound to a nginx instance that plex is being routed through and then through cloud flare.

Looks like Dtech is having the same issues so I believe he will update on a possible fix once he figures it out.


#5

Update before I go to bed

Looks like other people are having the same issue so it might not be a letsencrypt issue

Temp solution atm is to Clear the custom url setting, save, and then re input the URL in the network tab and that seems to make the plex server reachable again you will have to do that every-time plex media server restarts.

Although we still have the issue of it not being a secure connection so Im not even sure if things are still being routed through cloudflare


#6

so i am using this setup and in the past couple of days now im having issues even using the temp fix my videos buffer over and over


#7

Temp fix didn’t seem to help me for long, lasted a couple of hours maybe not sure how to fix it thinking of scraping Hetz and going back to SyS


#8

I have SYS in CA. I believe cloudflare streaming may have broke because yesterday even when i got my server to show up or using it on web interface i noticed i would just get lots of buffering. My internet speedtests showed decent speeds and i speed tested my server to my ISP and got decent speeds. I was able to pull a file via FTP at 1 mb/s constant but could not stream a file at 1.5 Mbps without buffering. However my cell phone on verizon could stream at 8 Mbps. So when i did route through cloudflare before i never had slow downs or issues. I wonder if they somehow disabled plex being routed through it.