Issues with Apache after using Letsencrypt


#1

Hi all

I have installed Quickbox, latest 2.4.4 version on my seedbox, clean ubuntu 16.04 install.

When i tried to use the guide on the wiki for using letsencrypt it suddenly stopped working, and now i just get the following message when trying to access my https://mydomain:
Error code: SSL_ERROR_RX_RECORD_TOO_LONG

The following sed command did not work either:

sed -i “s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g” /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart

I got the following message when doing that:
sed: can’t read /etc/apache2/sites-enabled/000-default-le-ssl.conf: No such file or directory

Anyway, does anyone have any idea on how i can fix this or just revert back to the old configuration files for the “standard” ssl? Because as of right now my webserver to access everything does not work at all.


#2

When you ran the lets encrypt installer, you were given a choice between like 3 files. one was like default-ssl.conf and another was 000-default.conf. Which one did you pick?

I would re-run the installer portion of lets encrypt and pick the 000-default.conf and then see what happens when you run the sed command.

edit: it might be: 000-default-ssl.conf


#3

Wohoo!

it works.

I ran the installerscript for Lets Encrypt again, which seemed to work strangely enough.

However i still had an issue where the “Apache2 default page” came up instead, which is what the sed command would have fixed. Weirdly enough it did not name the 000-default-ssl.conf that, it named the file just default-ssl.conf. After adjusting the sed command to that file everything worked again!

Cheers, thanks for the help.


#4

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.