Issues installing QuickBox

install

#1

Hello,

Just discovered QuickBox, and decided to give a try.
Of course, all wasn’t that good, so here I am.

Before givin,g the error, here what I got, and what i’ve done so far.

Server provider: SoYouStart - Dedicated server.
Distribution: Ubuntu Server 16.10 “Yakkety Yak” (NEW) (64bits)

EDIT: On the fresh install, SYS panel, i chose to set a custom install, saying raid0, as I saw it may increase my disk space and/or avoid error. (remember saw a post with a video on this forum, showing how to)(here it is)

On a fresh install, i login as root, and just type what QB told me to.
And here my settings, as simple as they can be.

At the very first start, I got an error.
As far as I remember, it was about an error line 206? saying iptables wasn’t a valid command.

After the install is done, I canno’t access the dashboard throught my browser. (xx.xx.xx.xx doesn’t accept connexion)
So I clic Y, to valid the restart.

I can login, and see I am running QuickBox v2.4.8.
uname -a: Linux QuickBox-Bart 4.8.0-26-generic #28-Ubuntu SMP Tue Oct 18 14:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Now stuck, and no idea what to do more to fix this issue.

here some line of the installation log file, in case it may help.
Just choose line with error or things which doesn’t ‘sound’ normal to me.

E: Unable to locate package build-essential
E: Unable to locate package debian-archive-keyring
E: Package 'python-software-properties' has no installation candidate
dpkg: error processing archive /tmp/apt-dpkg-install-Xst4EU/010-update-notifier-common_3.175_all.deb (--unpack):^M
 trying to overwrite '/etc/apt/apt.conf.d/10periodic', which is also in package apt-config-auto-update 2.0.0-1ubuntu1^M
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)^M
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
ERROR: Module auth_digest does not exist!
ERROR: Module ssl does not exist!
ERROR: Module scgi does not exist!
ERROR: Module rewrite does not exist!
Failed to restart apache2.service: Unit apache2.service not found.
Failed to enable unit: No such file or directory
Failed to restart vsftpd.service: Unit vsftpd.service not found.
Failed to enable unit: No such file or directory
Job for fail2ban.service failed because the control process exited with error code.
See "systemctl status fail2ban.service" and "journalctl -xe" for details.
Created symlink /etc/systemd/system/multi-user.target.wants/fail2ban.service → /lib/systemd/system/fail2ban.service.
Failed to restart quota.service: Unit quota.service not found.
Failed to enable unit: No such file or directory

The complete log file may be found here.

Of course, I can pay to get this installed, but I really prefer understand and learn, so…
Any help would be welcome

EDIT: Still searching on this forum, and trying.
So here what I tryed / tested.

box upgrade

after a bunch of line, it came to these error, at the end

cp: cannot create regular file '/etc/shellinabox/options-enabled/00_QuickConsole.css': No such file or directory
chmod: cannot access '/etc/shellinabox/options-enabled/00_QuickConsole.css': No such file or directory
chmod: cannot access '/etc/shellinabox/options-enabled/00_QuickConsole.css': No such file or directory
mv: cannot stat '/etc/init.d/shellinabox': No such file or directory

Trying this
cat /srv/rutorrent/home/db/interface.txt
and got the result: eth0


#2

This actually looks like nothing (no dependencies) got installed on your system. I can see from that log file that apache never got installed either.

Will you type apt update and tell me if it returns an error?


#3

Hello,

Thanks for the answer.

The output is:

Hit:1 http://archive.canonical.com/ubuntu yakkety InRelease
Hit:2 http://archive.ubuntu.com/ubuntu yakkety InRelease
Hit:3 http://archive.ubuntu.com/ubuntu yakkety-security InRelease
Hit:4 http://archive.ubuntu.com/ubuntu yakkety-updates InRelease
Hit:5 http://archive.ubuntu.com/ubuntu yakkety-backports InRelease
Hit:6 http://ppa.launchpad.net/ondrej/php/ubuntu yakkety InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.

Which lead to:

apt list --upgradable -a

Listing... Done
openssl/yakkety 1.0.2j-1+deb.sury.org~yakkety+1 amd64 [upgradable from: 1.0.2g-1ubuntu9]
openssl/yakkety,now 1.0.2g-1ubuntu9 amd64 [installed,upgradable to: 1.0.2j-1+deb.sury.org~yakkety+1]

#4

Wonderful. What is the output of service apache2 status?


#5

Hello,

here it is.

Unit apache2.service could not be found.

EDIT: Here the output who may help

    service --status-all
 [ - ]  apache2.dpkg-new
 [ + ]  apache-htcacheclean.dpkg-new
 [ + ]  bind9
 [ - ]  console-setup.sh
 [ + ]  cron
 [ + ]  dbus
 [ - ]  fail2ban.dpkg-new
 [ + ]  grub-common
 [ + ]  hddtemp
 [ - ]  hwclock.sh
 [ - ]  ipmievd
 [ + ]  irqbalance
 [ - ]  keyboard-setup.sh
 [ + ]  kmod
 [ - ]  lvm2
 [ + ]  lvm2-lvmetad
 [ + ]  lvm2-lvmpolld
 [ - ]  mdadm
 [ - ]  mdadm-waitidle
 [ - ]  memcached.dpkg-new
 [ + ]  networking
 [ - ]  openvpn.dpkg-new
 [ - ]  php7.0-fpm.dpkg-new
 [ + ]  procps
 [ - ]  rsync
 [ + ]  rsyslog
 [ - ]  screen-cleanup
 [ + ]  smartmontools
 [ + ]  ssh
 [ - ]  thermald
 [ + ]  udev
 [ - ]  unattended-upgrades
 [ - ]  vnstat.dpkg-new
 [ - ]  x11-common.dpkg-new

#6

Will you show me the results of …

cd /root
ls -l

#7

Hello,

Here it is.


#8

Will you type apt-get -f install to see if it pulls additional needed dependencies? Looks like Deluge from Repo caused an issue in your logs… also, you were using the ovh.mirror archives to pull some of the initial setup dependencies… it looks like these specific depends are not pulled from their source. I may have to tweak the placement of the overwrite of sources.list on the installation. Not sure why this randomly happened to you, however, I am going to test this against a couple of 16.10 installs shortly.


#9

Hello,

Thanks for your help.

Here the output.

   apt-get -f install

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  update-notifier-common
Suggested packages:
  policykit-1
The following NEW packages will be installed:
  update-notifier-common
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
373 not fully installed or removed.
Need to get 0 B/161 kB of archives.
After this operation, 1,411 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y

(Reading database ... 66046 files and directories currently installed.)
Preparing to unpack .../update-notifier-common_3.175_all.deb ...
Unpacking update-notifier-common (3.175) ...
dpkg: error processing archive /var/cache/apt/archives/update-notifier-common_3.175_all.deb (--unpack):
 trying to overwrite '/etc/apt/apt.conf.d/10periodic', which is also in package apt-config-auto-update 2.0.0-1ubuntu1

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/update-notifier-common_3.175_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am not that familiar with *UNIX system.
I have installed my server from OVH distrib, as I’m not sure I can do without.
But during the install it came to ask me if I wanted to install the distribution kernel, and then, restart the server. it didn’t mean that it was changing the Ubuntu version, or something like that?

Would I get better result by using a lower Ubuntu version, or Debian 8?

EDIT: Just as a note.
I tried to install to official Ubuntu, after a complete server wipe.
Still got same issues.


#10

Even though we have included support for 16.10, I personally have not been able to test an installation on that environment. Is there a reason you’ve chosen 16.10 over 16.04? I have tested installs of QuickBox on 16.04 over many machines at OVH and SYS and I’ve never seen these issues pop up. It’s entirely possible OVH has snuck something into the configuration of the Ubuntu install with 16.10 that is conflicting with our setup. Have you attempted the installation on a fresh install of 16.04?

Further, I trust you are cloning the repo to the proper location? (ie /root/QuickBox)

I am not sure what you mean by “Ubuntu Official” as all options to install Ubuntu should be official. The question regarding the distribution kernel affects the kernel and nothing else. This step is required and the installer will exit if you decline.


#11

Hello,

I choose 16.10 over 16.04 because this is the ‘‘newest’’ version, and I thought it would be a good thing.
I am currently trying a setup on 16.04, and will update this topic for sure as soon as I’ll get news.
(about 30-40min from now I guess)

I am cloning the repo from /root, and so, I got the dir /root/QuickBox.

About the Ubuntu question, this was a missspellled sentence, since I’m a newbie.
I apologize for this.

EDIT: With Ubuntu 16.04, it seems it is working.
I am checking whatever I can, but all seems good =)


#12

i can say i ran into this myself on another install i let @JMSolo know but forgot to pull logs before reinstalling and downgrading to 16.04


#13

Running 16.10 on Hetzner and having no issues here. Seems it may be OVH interference.


#14

Definitely an OVH issue. I’ll need to get my hands on one so I can examine what exactly is failing. Looks like the OVH mirrors initially being used as the sources for apt are what is causing the issue. In the beginning if the python-software-properties do not install initially then it could throw the script awry.

I’ve added in the update command directly after the new sources.list are imported. Hopefully the resolve is this simple… but judging by the logs, it looks like this may be the culprit.

###Commit for verification


#15

i can give you access a server running the ovh template Ubuntu Server 16.10 “Yakkety Yak” (NEW) i have running currently it expires on the 10th but your free to use it shoud you require

cheers


#16

Hi!
@JMSolo or @liara, any fix for this in Ubuntu 16.10??

I have exact the same issues…
New server on Kimsufi, same distribution, same errors in log (iptables not found), same output from the commands executed in the server for diagnostics…

It´s a new server, so I can reinstall all and try all you want…

Thanks!


#17

its something in the ovh img of the OS.


#18

I’m having this issue as well, I’m using the distribution kernel (not OVH’s custom one) and am trying to do a clean install, however I’m getting /root/QuickBox/setup/quickbox-setup: line 206: iptables: command not found on the latest version of QuickBox.

Any solutions yet?

edit: I’ll just use 16.04.


#19

it’s the custom kernel they use. My server was using a custom old beta kernel. Once I updated the kernel all installation problems disappeared.


#20

This may be a fluke on my end. During the install of your OS at SYS. You can check the box for custom install, during that I was able to select to use the kernal dist. QuickBox is installing as we speak and I dont have any errors.