Installation on Scaleway C1


#1

I have installed this script on Online/SYS/OVH it worked like charm.
Recently I tried installing it on Scaleway C1 Baremetal server, at the end of script when the script reboots the server it does not start the server. Any one who has installed it on Scaleway could assist me please.

Thanks & Regards.


#2

Could you reboot your server from the Scaleway panel?


#3

Yes there is an option to reboot the server.

Please have a look at the reboot options :- https://s32.postimg.org/5ivkbtiyt/Untitled.png
I had selected the Archive option for reboot.

EDIT: The server starts but when I visit my IP address it says server not found.

Thanks Man, Really appreciate it.


#4

wouldnt you want the hard reboot?


#5

i tried hard reboot too but the issue still remains.


#6

I know @liara does a lot of testing on Scaleway and she hasn’t had any issues that I am aware of. If you would like, send me a PM with your server details and I will login and see what I can find. If you are getting a server not found error, then this could be due to dependencies not getting installed, thus apache didn’t either.

Just to confirm, you did install it as root and from the /root directory correct?


#7

I have never used a scaleway c1 for testing. I avoid them due to the arm architecture. I’ve gotten it to build on the VC vps and the C2s though. The only quirk I’ve found is that scaleway enables auto updates which is a conf file that messes up the flow of the installer.

The offending files are in /etc/apt/apt.d

The main file is the unattended upgrades configuration that needs to be removed. I usually remove everything in that folder, but I just test and don’t use it for production and that might remove something you might regret later on


#8

@JMSolo, I will PM you the SSH details.
@liara I agree with you, it works good with the VC1 but not with C1. ARM messes up things i guess.


#9

The architectures have different needs and a lot of the software needs to be ported to work on a different architecture. I believe the C1 is in a similar position as RaspPi


#10

what os are you using for the top one becasue some of the ubuntu trees have the compiled stuff that most systems need to run the same programs on arm