Installation kills sudo priviliges


#1

Hello,

I am trying to install quickbox on ubuntu 16.04. I recently formatted my old i5 pc and installed ubuntu. Now I am trying to install quickbox on it, however, whenever I copy and paste the necessary code, “sudoers” file gets damaged. I lose sudo privileges.

I read various articles how to solve this issue but I need a stable solution. I don’t want to edit files when this happens.

This error happened when I tried to install quickbox. My computer restarted itself for no reason and this problem was begun.


#2

are you using ubuntu server? and not desktop i hope.


#3

I am unfortunately using desktop… Why is it so bad? It is my old pc thats why I installed desktop


#4

desktop is completely different environment and will ultimately do more harm with quickbox than good XD trust me i tried :wink: server is command line only but once quickbox is installed you no longer need keyboard and mouse or any of that you can manage torrents over http with any computer in your house all you need is the server address that comes from your router.

best bet is to grab a iso from ubuntu site for the server and install then try script again.


#5

I managed to solve my problem by updating the software. I believe I can use quickbox like this but do you strongly recommend that I install server iso? What will be a huge difference? One of the reasons I installed desktop is that I am completely a noob when it comes to linux, command line etc.


#6

this script was made with noobs in mind :stuck_out_tongue: so no worries there. and yes server is highly recommended
desktop will use resources that could be used for the seedbox so even if you get seedbox running you would be killing your overall experience by loading down the hardware with unnecessary software. this being said you are more than welcome to use on desktop but i would not recommend it. also do not think any of the other staff would either.

the only commands you need are
sudo su
cd
then enter the install commands
after that it walks you though like it did before.


side note i am off to bed so have a good time playing with it if you still need help someone can help you more in a few Hrs. or you can wait tell i am back on in 7 hrs or so


#7

I now installed ubuntu server on my pc and tried to install quickbox. Thanks to dtech now I am root in the command line. However, when I tried to clone Quickbox, I got an error saying

Cloning into ‘Quickbox’…
fatal: unable to access ‘https://lab.quickbox.io/QuickBox/QuickBox’: Could not resolve host: lab.quickbox.io

any ideas?


#8

Check that the time on your computer is up-to-date


#9

it seems correct. I have my ethernet cable connected but I am not sure if I am connected to the internet and don’t know how to in ubuntu server. Can you help me?


#10

If you can open command prompt, type in date and see if the date is correct.


#11

I meant how can I be sure about the internet connection :). By the way,
the date is correct.


#12

I can’t really help you with the internet connection as you have this on a home connection. Unfortunately, troubleshooting your home network is not within our scope of support.

Additional to the error:

fatal: unable to access ‘https://lab.quickbox.io/QuickBox/QuickBox’: Could not resolve host: lab.quickbox.io

This means that the timestamp on the system attempting to download the repo is not correct in regards to the date of our SSL certificate. You are more than likely not set properly on your home servers date, thus the SSL certificate fails and you cannot download the repo.


#13

thanks for the help! i will try my best to solve it


#14

Could not resolve host is often indicitave of a nameserver not being configured.

ping 8.8.8.8
ping google.com

If you are able to ping 8.8.8.8 but not google.com then you need to configure a nameserver either in the network interface (/etc/network/interfaces) or /etc/resolv.conf