I botched my install of Quickbox. Everything is still running but the UI


#1

So I was having problems getting Letsencrypt to work. I was stuck at the end of Option 1 where I was trying to set the config file for SSL. Every time I would run that command I would get an error back saying it couldn’t establish an TLS connection on port 430 of the ip. After looking at the config files I noticed that the one I was supposed to choose wont check for TLS or port 430. So I tried with the right config file and I still got the same error. Notcing in the install instructions that choosing the wrong file might force me to reconfigure apache I then took off to Google to find out how to reconfigure it. Well the first site I found just had commands to remove apache and then reinstall. Well after uninstalling apache I tried to reinstall. I then got an error near the end of the install when it’s trying to setup apache2. Well after many attempts to install and reinstall apache and try to reinstall Quickbox I’m stumped in how to fix this without having to do a full reinstall of the OS. I wouldn’t mind doing a full reinstall actually if I could get gparted to work so I can move my torrents to somewhere other then the home directory. Anyway does anyone have any suggestions? I’m running Ubuntu 16.04 and I can X2go into my box and see that the box is running fine and Plex still shows my server is still working. It’s just the front end GUI is gone for me

Edit: So it looks like the error is coming from the default-ssl.conf file. I finally found the error log and it’s saying that SSLPassPhraseDialog is an invalid command. Probably referencing a module that I deleted which didn’t get picked up on reinstall of apache. That part of the code in the file is above the first vhost tag so I’m not sure if it’s supposed to be there or not.


#2

Have you tried to reinstall QuickBox over the top of the existing installation?

What problem are you having when trying to move torrents to other directories?

If you have nothing on the server of value, it may just be easier to reinstall.


#3

I just ended up just wiping the server and starting fresh. I tried reinstalling Quickbox on top. There is a thread here I saw that showed how to do it but that didn’t help.

I was hoping if I could create another partition and throw all my torrents on there then I could reinstall the OS without losing anything. From what it looks like on Hetzner web page they wipe the whole drive when you install a new OS. So I just took my loses (the server has only been up 2 weeks) and formatted the whole thing. I didn’t lose a huge amount that I can’t get back but my ratio is going to take a hit to recover. Now I have a reason to do the whole ACD backup for next time. I’m trying my best not to be a Linux newb but that will take some time for sure.