HTTPS " Not Secure"


#1

I logged into my server today, and it says its not safe to go to the site and that the HTTPS has expired, I purchased it through the quickbox package a couple months ago.


#3

#4

solved with post