HTTP Error 500 in links created by Rutorrent File Share plugin

fileshare

#1

I am trying to share some files but when someone clicks the link provided by the plugin it will output a HTTP ERROR 500 message.

I have tried uninstalling the plugin from the dashboard and installing it again but it didn’t work.
Now the plugin will allow me to create 1 hour duration links instead of 24 hours and none of the links I create will actually work. They all output the same error.

I had used it before and it worked fine. I even tried rebooting the server but nothing happened.


#2

I think this may had gotten botched on the recent ruTorrent update that was done. I will look into this now to confirm. Thanks for reporting this.

It seems this may be an issue with installing/uninstalling the plugin as I just tried on a fresh install and the issue does not exist… so I don’t think the update is not to blame. I am however going to patch this over to the plugin install/uninstall system commands to help other users avoid this in the future.

You can do this in the meantime to fix this issue:

local_setup=/root/QuickBox/setup/
cp ${local_setup}templates/rutorrent/plugins/fileshare/conf.php.template /srv/rutorrent/plugins/fileshare/conf.php
cd /srv/rutorrent/home/fileshare/
rm -rf share.php
ln -s ../../plugins/fileshare/share.php


####Update has been pushed. Here is the commit:
https://github.com/QuickBox/quickbox_packages/pull/75/commits/5ca0e9ed3d5a9cf7b20b7adef46bdfde1d5e6385


#3

Thank you for a fast solution. :smiley:
It works fine now.