Hox to access QB with https://ip/rutorrent/home instead?


#1

hello all,

i want to acces to Quickbox not using http(s)://127.0.01 but using https://127.0.0.1/quickbox (or /rutorrent/home) and use the https://127.0.01 for Muximux.

as a total noob on linux/apache2, i dig, and so far i have sucess to load muximux as default page, or load muximux as https://127.0.0.1/Muximux wit quickbox on default,

for now, https://ip lead to muximux, but when i try https://127.0.0.1/rutorrent/home( or /index.php), wich seems to be the main quickbox page, blank page :’(

any help would be apreciate on how to allow /rutorrent/home as a valide url


#2

Hi,

I’m trying to play with Apache too for the same reason.

Did you succeed ?

jé’


#3

yes and no ^^

i have read that muximux cant access http if it is set in https, but it still can access https sites if set as http.

so i have set port 80 to listen to muximux, and i have set default page on muximux to https://IP, and it work well :slight_smile:

after installed quickbox, just copypast all this, it will install Muximux to /srv/Muximux and change quicbox config for muxi on http://IP

then you will have to set muximux config with webui

copy past that as root, at least it worked for me :slight_smile: if anny issue, there is a .bak of apache config file

echo '##########'
echo '# install  Muximux '
echo '##########'

apt-get install git
cp /etc/apache2/sites-enabled/default-ssl.conf /etc/apache2/sites-enabled/default-ssl.conf.init
cd /srv
git clone https://github.com/mescon/Muximux.git
chown -R www-data.www-data /srv/Muximux
sed -i -e 's/<VirtualHost \*\:80>/<VirtualHost \*\:80>\n        DocumentRoot \"\/srv\/Muximux\"\n        <Directory \"\/srv\/Muximux\/\">/' /etc/apache2/sites-enabled/default-ssl.conf 
sed -i -e '/<Directory \"\/srv\/Muximux\/\">/{n;s/.*/##&/;}' /etc/apache2/sites-enabled/default-ssl.conf 
sed -i -e '/##/{n;s/.*/##&/;}' /etc/apache2/sites-enabled/default-ssl.conf 
sed '/<key><Directory \"\/srv\/Muximux\/\"><\/key>/!b;n;c<string>###</string>' /etc/apache2/sites-enabled/default-ssl.conf 
sed -i -e 's/##/#/' /etc/apache2/sites-enabled/default-ssl.conf 
service apache2 restart