How to disable transmission whitelist?

#1

Hi all.
I just installed quickbox community on my new little VPS.
All’s fine, but I installed Transmission, I prefer cause I’m using transmission remote GUI on my Xubuntu computers…
But I’v got a little problem…Impossible to disable whitelist.
Can you explain me how to do this?
I changed to “false” in root the settings.json, but no change…
Thx!

#2

Before you modify the settings.json, you need to confirm which version of the quickbox community you are running. the config file has been moved to the

/home/${username}/.config/transmission/

In additional, you have to stop your transmission service before you edit the config file.

#3

Hello.
Thx for your answer.
I’m using latest version of quickbox.
Ok, I’ll stop transmission before editing file.
And after, I can restart normally the daemon ?

#4

Yep, you can simply restart the daemon with botton in dashboard. The service is now called [email protected]$yourusername.

#5

Sorry but i can’t do this…
Each time I restart transmission, the olf file is loaded, and rpc whitelist parameter is on true…
I’m doing something wrong, but what?Can you give me exactly commands I have to enter?

My method:
systemctl stop transmission-daemon.service (in root)
nano settings.json-> rpc whitelist to false
ctrl+O to save file
ctrl+X to quit nano
click to refresh button to relaod transmission

what’s wrong?

#6

I think, it’s because of the wrong service name. In order to solve the permission problem, I used user permission to run transmission(it was added in the latest CE)
systemctl start [email protected]$username
the transmission-daemon.service still exist, but it will use the config in /etc/transmission/ with debian-transmission.
So you have to

  • stop the service with systemctl stop [email protected]$username
  • modify the /home/${username}/.config/transmission/settings.json
  • start service via systemctl start [email protected]$username
#7

Great!
All is perfect now, really thx!
Last question, is it possible to desinstall rtorrent and IRSSI-autoDL?

#8

you can disable them in dashboard, and also able to uninstall manually.

#9

Ok thx.
but I’ve got a new problem…
For some reason, all of the newer torrents I had added would start, and then after a few seconds they would automatically pause. Each one said Error: Permission Denied. Every time I restarted them, they would pause again…
I think it’s a right problem, because there is no problem with rtorrent.
Only problem with torrent from public tracker.
However, I aggree with public tracker during install…How to check?

#10

I think it’s really the problem of permission. You’d better check the permission of your download or finished download dir. Please make sure that folder have write access with your user account(not root).

#11

finaly, there is not a permissions problem, cause there is no problem with a private tracker…

#12

odd. I have never seen such problem, I think it require more details of your config(as well as your server info) to figout the reason.