How to change rutorrent in *site* is requesting your username and password. The site says: “rutorrent”


#1

This is the message you get when you attempt to login to your server dashboard

how to change the part that says “rutorrent” without breaking something

the part where it says The site says: “rutorrent”

thanks!


#2

Hello @js8as,

I tried with my server but I can’t see any message regarding “rutorrent”.

Could you join a screenshot please?


#3

Are you talking about the password prompt?

You can change it in one of the config files in /etc/apache2/sites-enabled/alias-seedboxes.conf

You’re looking for AuthName under directory :slight_smile:

Fyi in chrome the prompt doesn’t even show the name


#4

You’re right, I did not see it with Google Chrome but it is displayed with IE :wink:
I updated the GUI this morning and it seems JMsolo has made somes changes.

Please make a backup of the aliases-seedbox.conf file with : sudo cp aliases-seedbox.conf aliases-seedbox.conf.bkp before modifying it.

You can modify the file with : sudo nano /etc/apache2/sites-enabled/aliases-seedbox.conf


#5

Yeah, that’s what I was looking for. thanks!


#6

after changing this option and restarting apache. I can’t seem to login anymore when I input my credentials the server just asks for the login info again in an endless loop.

I had to set it back to the default for it to work again.


#7

Can you post a copy of your .Conf file (the one that’s giving trouble) ?


#8
Alias /rutorrent "/srv/rutorrent"
<Directory "/srv/rutorrent">
  Options Indexes FollowSymLinks MultiViews
  AuthType Digest
  AuthName "rutorrent"
  AuthUserFile '/etc/htpasswd'
  Require valid-user
  AllowOverride None
  Order allow,deny
  allow from all
</Directory>
Alias /USERNAME.rtorrent.downloads "/home/USERNAME/torrents/rtorrent/"
<Directory "/home/USERNAME/torrents/rtorrent/">
  Options Indexes FollowSymLinks MultiViews
  AuthType Digest
  AuthName "rutorrent"
  AuthUserFile '/etc/htpasswd'
  Require user USERNAME
  AllowOverride None
  Order allow,deny
  allow from all
  php_admin_value engine Off
</Directory>
Alias /USERNAME.deluge.downloads "/home/USERNAME/torrents/deluge/"
<Directory "/home/USERNAME/torrents/deluge/">
  Options Indexes FollowSymLinks MultiViews
  AuthType Digest
  AuthName "rutorrent"
  AuthUserFile '/etc/htpasswd'
  Require user USERNAME
  AllowOverride None
  Order allow,deny
  allow from all
  php_admin_value engine Off
</Directory>
<Location "/USERNAME">
    AuthType Digest
    AuthName "rutorrent"
    AuthUserFile "/etc/htpasswd"
    Require user USERNAME
</Location>

#9

and the moment you change

AuthName "rutorrent" 

it gives you trouble?

Anything special about the new authname? special characters etc?

When I cat /etc/htpasswd I get:
myusername:rutorrent:hashedpassword

I wonder if the :rutorrent: but needs to match the auth name?

I have no idea by the way, might be worth reacing out to the unix goddess @liara and hopefully she’ll grace us with an answer :slight_smile:


#10

its just a word, no special letters or numbers at all.

does it work as expected on your end?


#11

I’ll take a look tonight when I’m at the computer :slight_smile:


#12

We use htdigest to create the realm/password hash. If you use a realm it must be consistent across all calls otherwise authentication will fail

Usage:
htdigest /etc/htpasswd realm username


#13

so if @js8as wanted to change the “rutorrent” password prompt, he could type:

htdigest /etc/htpasswd myservername js8as 

?

I remember it being gods in swizards :slight_smile:


#14

Yep! Just make sure that myservername or whatever realm you do choose is also defined as the realm in the apache configs!