How do i disable http authentication?


#1

For some reason I cant login to sonarr/rutorrent. It keeps me in a loop of http authentication. I know I’m using the correct username and password.

I can get onto quickbox/deluge/jackett just fine.

Could this be a proxy pass issue?

How do I disable this or make it work?

thankyou.

Edit - I’ve found in my phone I can login to rutorrent but not sonarr. so it’s definately not a wrong password


#2

What happens when you use: https://USERNAME:[email protected]/rutorrent ?


#3

thanks for your reply…

that works great for rutorrent.

sonarr however still pops up with an authentication screen. and it fails on password entry.


#4

Try deleting and old cache and cookies


#5

no luck with clearing the cache…

the user:[email protected] method doesnt work every time.

I’ve tried on another computer and on my phone and it has the same problem. and sonarr especially. cant login to it at all.


#6

think i might have to go with disabling it for sonarr, anyone know how i do that please?

edit - I’ve worked out if i tunnel to the server then access sonarr it works. so its a proxy pass problem isn’t it?how do i fix it?


#7

Did you enable basic auth for sonarr? The two methods of auth conflict with each other.

Login with Apache -> sonarr requests login. Cookie gets replaced, Apache loses its auth, page refreshes and Apache asks for auth again.


#8

it was disabled. ok… to get it to work i went into sonarr advanced settings and changed bind address to “*” in the general tab.

however I’m noticing the password box keeps randomly popping up for rutorrent again… but if i cancel it i can still use it… strange.

anybody have any further ideas?


#9

Are you attempting to access your box via http:// or https://? I do know that connecting via http:// will result in two auth screens… one for normal port 80 behavior, followed by the redirect/actual url/port 443. Outside of that, I can’t think of why this would be happening to you without some sort of files being modified on your end as this is not normal/reported behavior.

This makes no sense. Not sure why it would work sometimes and not others… You may have to dig into your logs to see what is going on with your end as this has not been reported outside of this thread. If anyone else can confirm this is happening, I will dig deeper into it. I myself am not hitting this issue.