Hosting website along Quickbox


#1

Hello,

I’m stuck in this situation:
I got a Hetzner dedi, with 2 IPs.

Quickbox is set up fine on the main ip.
Now I want to host a different website on the second ip, and point my domain to that second ip.

I use cloudflare’s nameservers for my domain, and have an A record set on cloudflare to the second ip.
I made a new .conf file (vhost) in ‘/etc/apache2/sites-enabled/’ and activated it.

A mayor problem is that when I browse to https://newdomain.com/rutorrent I go to rutorrent, same with all quickbox apps and their urls.

How do I disable the ‘aliases-seedbox.conf’ file for my new vhost?


#2

you can change the setting in /etc/apache2/sites-enabled/default-ssl.conf.
you will find following code:
<VirtualHost *:80>
</VirtualHost>
<VirtualHost *:443>
</VirtualHost>
if you change the * to your ip, this rewrite will be locked to that interface.
then, you can create another rewrite rule


#3

I’ve done this already, changed the * to the first ip (the ip I want quickbox to use).
Still the same problem


#4

did you set another conf for your vhost(with second ip and the “newdomain”)


#5

Yes I got newdomain.com.conf set up and activated, listening to the second ip


#6

Somehow the newdomain.com.conf seems to think it needs to apply the ‘aliases-seedbox.conf’ file, which should only be for quickbox.


#7

the new conf should work if you set the correct VirtualHost ip, ServerName and DocumentRoot, and restart the apache2 service.


#8

This is my current newdomain.com.conf

This is my default-ssl.conf


#9

maybe you can try to change the ports.conf. just like Mixed port-based and ip-based virtual hosts in http://httpd.apache.org/docs/2.4/vhosts/examples.html
But I’m not sure if it works.


#10

I don’t there’s anything wrong with the ports, I’m using 2 ips so they shouldnt conflict.
I just need to figure out how to only enable aliases-seedbox.conf for the first ip/vhost which hosts quickbox and disable it for my second ip/vhost which hosts a entirely different site.


#11

cut the config in aliases-seedbox.conf, paste them here

<VirtualHost QUICKBOXIP:443>
...

SCGIMount /jesper 127.0.0.1:17362
[config in aliases-seedbox.conf]
</Virtualhost>

delete the aliases-seedbox.conf. then restart the apache2 service. these rewrite rule will only work for this ip based vhost. I tested in my server(localhost with a simple html, and the public ip with the qb dashboard)


#12

This works, I thought of this earlier but didn’t expect it to work.
Thanks, but I think some conf files get wiped with quickbox updates, so this is not really a long term solution.

Still thanks a lot!