Git grab bug on a vm


#1

error: no such remote ref 32276efb481ec7c021cabde8b1d519dda69f5999
Fetched in submodule path ‘dashboard’, but it did not contain 32276efb481ec7c021cabde8b1d519dda69f5999. Direct fetching of that commit failed.
this was on a debain vps that i ran at home


#2

Testing this now. A recent update may had botched the submodule.


#3

Alright, it was indeed a faulty reference on a submodule.

Here is verification:

[email protected]:~# git clone --recursive https://github.com/QuickBox/QuickBox QuickBox
Cloning into 'QuickBox'...
remote: Counting objects: 222, done.
remote: Compressing objects: 100% (95/95), done.
remote: Total 222 (delta 46), reused 0 (delta 0), pack-reused 127
Receiving objects: 100% (222/222), 25.54 KiB | 0 bytes/s, done.
Resolving deltas: 100% (104/104), done.
Checking connectivity... done.
Submodule 'dashboard' (https://github.com/QuickBox/quickbox_dashboard.git) registered for path 'dashboard'
Submodule 'packages' (https://github.com/QuickBox/quickbox_packages.git) registered for path 'packages'
Submodule 'rtplugins' (https://github.com/QuickBox/quickbox_rutorrent-plugins.git) registered for path 'rtplugins'
Submodule 'rutorrent' (https://github.com/QuickBox/quickbox_rutorrent.git) registered for path 'rutorrent'
Submodule 'setup' (https://github.com/QuickBox/quickbox_setup.git) registered for path 'setup'
Cloning into 'dashboard'...
remote: Counting objects: 992, done.
remote: Compressing objects: 100% (280/280), done.
remote: Total 992 (delta 37), reused 0 (delta 0), pack-reused 712
Receiving objects: 100% (992/992), 2.10 MiB | 2.39 MiB/s, done.
Resolving deltas: 100% (461/461), done.
Checking connectivity... done.
Submodule path 'dashboard': checked out '58a4696263a98b5321f09c3f82342671d5ec0954'
Cloning into 'packages'...
remote: Counting objects: 1270, done.
remote: Compressing objects: 100% (145/145), done.
remote: Total 1270 (delta 62), reused 0 (delta 0), pack-reused 1125
Receiving objects: 100% (1270/1270), 162.79 KiB | 0 bytes/s, done.
Resolving deltas: 100% (842/842), done.
Checking connectivity... done.
Submodule path 'packages': checked out '151fc45c8e7eefdb89cf37705862ca479b0915ea'
Cloning into 'rtplugins'...
remote: Counting objects: 2591, done.
remote: Compressing objects: 100% (400/400), done.
remote: Total 2591 (delta 58), reused 0 (delta 0), pack-reused 2191
Receiving objects: 100% (2591/2591), 1.71 MiB | 2.52 MiB/s, done.
Resolving deltas: 100% (228/228), done.
Checking connectivity... done.
Submodule path 'rtplugins': checked out '2a5054f3c4092dc0694b9c9a5817b0c8fa403563'
Cloning into 'rutorrent'...
remote: Counting objects: 2356, done.
remote: Compressing objects: 100% (51/51), done.
remote: Total 2356 (delta 9), reused 0 (delta 0), pack-reused 2305
Receiving objects: 100% (2356/2356), 1.99 MiB | 1.79 MiB/s, done.
Resolving deltas: 100% (175/175), done.
Checking connectivity... done.
Submodule path 'rutorrent': checked out '6dd42ca06678a82c742f941fb188a8e79a6163ea'
Cloning into 'setup'...
remote: Counting objects: 1583, done.
remote: Compressing objects: 100% (772/772), done.
remote: Total 1583 (delta 799), reused 1565 (delta 781), pack-reused 0
Receiving objects: 100% (1583/1583), 9.13 MiB | 2.80 MiB/s, done.
Resolving deltas: 100% (799/799), done.
Checking connectivity... done.
Submodule path 'setup': checked out '796b0af4127196fd6df0f7ea6aa03bcfac377ec4'
[email protected]:~#

#4

i knew somthing was not right


#5

Yup, for you… you can just do rm -rf ~/QuickBox and run the install commands again. You’ll be solid.