Ftp error > 426 Failure writing network stream


I have a dedi server from oneprovider / online.net.

IT ran flawless for 4 years with another install script one of my friends had written. But then irrsl auto download got broken so i decided to re-install using quickbox script.

Oneprovider only ubuntu server image was 14.04 so i upgraded to 16.04 and installed quickbox. Like others i could not ping Ip address or telnet to the box.

The following guide took care of the problem

"I had a problem installing quickbox on an ST8 from online.net2 :
Server unreachable on port 4747, and ping down.

The problem comes from a conflict between Ubuntu and the Broadcom BCM5716 network card of some servers of Online.net or OneProvider
(So, not all, my SC2016 works fine).

I have not solved this problem alone (I quote my sources at the end for more clarity).

To check :

Will tell you the name of your PCI devices.
To solve this problem :

Install Ubuntu fresh
Install Quickbox until the end, but DO NOT REBOOT at the end.
Open another ssh session and log in using port 4747 and your seedbox masteruser.
Enter the following commands:
sudo su
cd /root
mkdir bcm
cd bcm
git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
cp -rf /root/bcm/linux-firmware/bnx2/ /lib/firmware

Not sure what the fix did but im guessing netcard drivers? but anyways it helped.

My problem is with the FTP server.

When i try to download files i get the error message in cuteftp
"150 Opening BINARY mode data connection for xxxxxxxxxxxxx (50000000 bytes).
426 Failure writing network stream.

I tried this fix
"I was getting errors when trying to download a file from a mounted windows share with vsftpd. The fix for this problem is to add use_sendfile=NO to your vsftpd.conf file."

It did not fix the problem.

Other pages talked about "Getting passive FTP connections to work through a firewall properly"
But im not sure what firewall is running to see ip ports need adding to system if that’s the problem.

Any idea on what to do about the 426 Error? And what might cause the problem?