FTP change port 5757 and enable SFTP on it?


Is it possible to change the FTP port from 5757 to another and enable SFTP protocal?
Would ProFTPd work along side QuickBox ok?


Sftp uses 4747, you should be able to change the port in vsftpd.conf, and yes you could also run proftpd.

I would like to have my friends use SFTP login instead of FTPS I am aware there no much if any differents.
But they are not able to use it due to me locking down SFTP with a public key only.

What is strange is if I do allow password to be used to login it doesn’t work either until I add the match user into /etc/ssh/sshd_config. But then it gives them access to the root files, which is why I said about ProFTPd.

Where as a plain install of Debian 10 same version does.

So am looking at setting up SFTP for them on another port.
I am testing out a few things using SSH with chroot and ProFTPd on a test server to see what works best, without them having access outside of their home directory.

Think I got what I want now with ProFTPd using SFTP was trying last night for a few hours and didn’t check the log files D’oh.
Quick Google of the error and fixed, that teach me.
It was the wrong key type that ProFTPd was looking for.

When I do the install for real and tested it, I will try and post a how-to, to get it working.

I have got it working for SFTP and couldn’t get FTPs work as I didn’t need it, I never looked into it.
I was using the wrong key type, found the answer after doing a Google, it needed RSA.
It also removes VSFTPd.

I would have done a how to but I wasn’t able to get both SFTP and FTP(s) working.