Fixing Disk Quota Display


#1

Having some trouble getting my disk quota display to function again. the setdisk command as root seems to run without any issues, but the dasboard’s quota display is still showing this:

So far I’ve tried:

fix-disk_widget_home
fix-disk_widget_root

both seem to be successful with no error message, but the display still doesn’t look right.

I’ve also tried running:

quotaoff -a
service quota stop
mount -o remount /
quotacheck -auMF vfsv1
quotaon -uv /
service quota start

but I get an error during the “quotaon -uv /” command

Mountpoint (or device) / not found or has no quota enabled.

lsblk output:

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 1.8T 0 disk
├─sda1 8:1 0 512M 0 part /boot/efi
├─sda2 8:2 0 1.8T 0 part /
└─sda3 8:3 0 1.6G 0 part [SWAP]
sr0 11:0 1 1024M 0 rom

cat /etc/fstab

/ was on /dev/sda2 during installation
UUID=b1f57779-c4ae-441f-b8b2-2d5c90da6428 / ext4 errors=remount-ro 0 1
/boot/efi was on /dev/sda1 during installation
UUID=71C9-146F /boot/efi vfat umask=0077 0 1
swap was on /dev/sda3 during installation
UUID=75417b14-0500-4e05-8e55-3f98c183e1d2 none swap sw 0 0

Pretty sure my fstab is the issue, but I dont have a lot of experience editing it. Any ideas on how I can fix this?


#2

Hello,
I had the same issue, i was resolved by disabling quotat for users on the / (root) disk

Hope it can help you.


#3

you need tosetdisk if you have quota installed.


#4

setdisk runs successfully, but nothing changes on that user’s quota display.

ie:

setdisk

Disk Space MUST be in GB/TB - Do not attempt to add decimals in space settings,
Example - Good: 711GB OR 2TB, Example - Bad: 711.5GB OR 2.5TB

Username: someusername
Quota size for user: (EX: 500GB):
100GB


#5

make sure your widget is using / and not /home.


#6

Is there an easier way, or is updating

/srv/rutorrent/home/widgets/disk_data.php

and changing most of the /home references to / the best method?