Ffmpeg open-ssl enable?


#1

Hi there

Im going on holiday to France next week and thought I’d rip the latest simulcast for an anime

So off to youtube-dl I go set it up and run it all goes like normal until I reach the m3u portion

I get the error message

“https protocol not found, recompile FFmpeg with openssl, gnutls or securetransport enabled”

Now as the massage suggests I went and found out how to compile it with the options I needed however this failed each and every time no matter what method I tried

I just wondered if quickbox might have an tricks I could use to enable the option I need since I’m seriously banging my head against a wall here

I’m on Ubuntu 16.4 with ffmpeg installed using the install of quickbox.io


#2

Try apt -y install ffmpeg and see if this addresses your issue. I am still trying to make time to fix the openssl issues that have occurred recently.


#3

Reading package lists… Done
Building dependency tree
Reading state information… Done
ffmpeg is already the newest version (7:3.3.2-1~16.04.york1).
0 upgraded, 0 newly installed, 0 to remove and 164 not upgraded.

Is the message I get when I run the command specified however when I run the youtube-dl command its still giving me the openssl error for ffmpeg

Is this a running issue then? I’ve been banging my head against my desk for days before I finally came begging for help lol

Thanks so much for looking into this solo really appreciate it after days of dead ends

EDIT

Sorry solo I’m about to make things more difficult I’ve just run the same command (apt -y install ffmpeg) on my raspi 3 and that has run the command no problem and now youtube-dl works fine (super happy) so I can only guess something on my main server is messed up


#4

When I see this, it tells me that you may have a dependencies lock. If you would like to send me a PM, I can take a look at this directly and see what I can figure out. 164 packages for your OS not upgraded means you could have quite a bit of dependencies that simply need to the upgrade.

What do you get if you run apt -y upgrade?


#5

Seems your spot on its current running away from me with upgrade text for my packages

I’ll send you a pm now with ssh details I’d be very grateful to you for looking into it for me judging by my needed upgrades I’m gonna guess I’ve missed something simple but I’d love to have it fixed

Thanks again your a lifesaver