Everything I touch these days breaks

sickrage

#1

I’ve been tinkering on my server. While doing so, I busted my sickrage web interface settings and I can’t seem to fix it. I can see the service is still running and it’s still adding stuff to rutorrent but I can’t access the web interface.

Some background: I installed letsencrypt today, it’s working fine.
Then I clicked on the sickrage link on the dashboard, it didn’t work. I hadn’t clicked on the link before but for some reason today I decided to click on it (usually I use http://MYIP/sickrage) which I have bookmarked. so I go into sickrage using http://MYIP/sickrage, it works. I go into settings and enable https…restart the service and now I get a proxy error…sigh

I tried going into home/USER/.sickrage/config.ini and changing the settings but that doesn’t work. I change the following values:

https_key = server.key to https_key = ""
enable_https = 1 to enable_https = 0
https_cert = server.crt to https_cert = ""

Whenever I restart the service, it just reverts to the previous settings. I’m tempted to delete the config.ini file and restart the service to see if it reverts back to the default configuration but I’m scared it breaks something else (like wipes my library). Ideally I want the reverse proxy to work properly with SSL, i.e. https://MY.DOMAIN/sickrage

Any suggestions?


#2

Before you go too far down this rabbit hole. Have you done a complete cleanse of your browser cache and history? It’s possible your browser database is simply storing the bookmark to the IP thus it spits out a proxy error when attempting to access it from another.

Additionally, can you still access it via the IP route? If so, this is certianly a case of cache.


#3

I tried to access it from different browsers and locations. And accessing it using the IP doesn’t work anymore :confused:


#4

I get this error when I try to access a HTTPS address behind the Apache proxy.

I just edited the config for (in my case couch potato) to allow all IP addresses instead of local host and access HTTPS via the port directly.

If your issue is the same as mine, turning off HTTPS in sickage and pointing the Apache configuration (sickrage.conf) back to the non secure URL should fix

Hope this helps

Edit: @JMSolo - why does Apache do this anyway? Is it because the cert doesn’t match the URL it’s expecting?


#5

You know it!

The domain is already validated via the Lets Encrypt certificate. This is expecting a port such as the standard 443, when the browser reads a validate certificate with an invalid port… boom. The workaround to avoid all the other unnecessary and time consuming configuration is to simply forward/mask the default port/connection to a secured sub/directory link.

You guys didn’t really think we put all this work into this so you’d have to do more… did you? :stuck_out_tongue:

In most cases, just turn it off. You should still be able to reach https://mydomain.com/couchpotato or /sickrage just fine as redirected by the QuickBox dashboard.


#6

Sorted. Thanks guys.