Error when installing Btsync

btsync

#1

Hello,

Some month ago, i installed Quickbox and used the Btsync services without any problem.
Two days ago, i have noticed that btsync was disabled and i could not enable it.

I have tried to reinstall it using the quickbox dashboard but i’ve got the same result so i tried to reinstall it via ssh.

Here is error message i’ve got :slight_smile:

user:/home/user# box install btsync
Installing btsync
sudo: unable to resolve host user

The user does exist so i don’t understand the error message.

I am running Debian 8 on my server.

Thank you for your help


#2

I have some news.

Despite the fact that it shows Btsync as disable, it works.

When i write https://mydomainname:8888/gui/ it works but it does not appear anymore in the quickbox dashboard.

Furthermore, i can’t open btsync using google chrome.


#3

I noticed this too when I installed BTSync many months ago. If you try doing an apt-get update inside a terminal you’ll see when it tries to update the BTSync packages the key will be out of date. Don’t remember the exact error. I would recommend reinstalling it from the Quickbox menu (after updating Quickbox) as it will grab the newest version which has now been renamed Resilio Sync.

Check out the upgrade notes here about migrating settings across. https://help.getsync.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux


#4

Thanks you are right.

My mistake was to uninstall it from the dashboard instead of using that command:

sudo apt-get purge btsync

Now, i reinstalled it and it works.


#5

Yeah, this is one of those unfortunate issues a service like QuickBox has… always juggling new applications updates… this becomes especially inconvenient when they decide to completely rename their packages and/or repositories. (not looking at Plexrequests or BTSync at all :stuck_out_tongue: )

We’ll have this all sorted in an upcoming update. Which will actually address a lot of little nuances.