Error Occured: Unable to copy config.xml


#1

This happens with both Radarr and Sonarr. Jackett also doesn’t work but does not give me anything. I’ve tried giving 775 permissions to both .config and my home folder but it still fails. This happens across two different machines, both from Hetzner.

I’ve done the following

  • Uninstall/reinstall Sonarr and Radarr.
  • Reinstalled Quickbox from scratch
  • format drive
  • run conmnand: apt-get -yqq update; apt-get -yqq upgrade; apt-get -yqq install git lsb-release; \
  • git clone https://github.com/QuickBox/QB /etc/QuickBox &&
  • bash /etc/QuickBox/setup/quickbox-setup
  • Run through install
  • box install letsencrypt
  • box install Radarr or Sonarr
  • check permissions on .config and Radarr/sonarr
  • run command: chmod -R 777 .config && chown jsykes:jsykes .config
  • run command chmod -R 777 Radar && chown -R jsykes:jsykes Radarr
  • Cry.

Not sure where else to go so any help would be awesome.

Screenshots
02%20PM
14%20PM

57%20PM
29%20PM


#2

A thing is annoying me from your second screenshot, you don’t have the /opt directory ?

And please what is the result of these commands (the last one) :

  • username=$(cat /srv/rutorrent/home/db/master.txt)
  • local_setup=/etc/QuickBox/setup/
  • cp ${local_setup}configs/Radarr/config.xml /home/${username}/.config/Radarr/config.xml

Normaly, you should have the config file after the last command above.


#3

cp: cannot stat ‘/etc/Quickbox/setup/configs/Radarr/config.xml’: No such file or directory

so the configs folder is missing from the the repo I pulled?29%20AM

EDIT: Digging a little deeper and the folder does seem to exist in /etc/ but I can’t access it, even when I am logged in as root.

39%20AM

if I run it as my QB user I get this

[[email protected]]:(0b)/root$ /etc/Quickbox
bash: /etc/Quickbox: No such file or directory
ls: cannot open directory '.': Permission denied```

as root:

server:~# /etc/Quickbox
bash: /etc/Quickbox: No such file or directory

but its definitely there…just can’t seem to get access to it.

EDIT 2: OK, found the problem. It seems that somehow the Quickbox folder has a trailing space at the end of it, which is why I can’t get access to it. deleted the folder using rm -rf Quick* then re ran the install script one line at a time with a slight modification

apt-get -yqq update; apt-get -yqq upgrade; apt-get -yqq install git lsb-release; 
git clone https://github.com/QuickBox/QB /etc/QuickBox/ 
bash /etc/QuickBox/setup/quickbox-setup

now the folder exists without the space, im going to try reinstalling the packages again. If not, complete reinstall and keep that slash in mind


#4

Ok, the corrected script + reformat and reinstall QB seemed to have fixed the issue. I haven’t installed letsencrypt yet but if it breaks Radarr, at least I know where it breaks now. Thanks for your help!


#5

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.