Error after trying to update

error
update

#1

I was running a version prior to 2.3 and I tried the commands to update I saw in another thread:

git clone https://github.com/QuickBox/quickbox_packages quickbox_packages
cd quickbox_packages/system
bash updateQuickBox

AfterI tried I got several errors and my dashboard looked like this:

It’s missing some stuff and the bandwidth meter is just a thin line.

The update messed with my sudoers file, because I am not able to use my username as sudo anymore and ssh login to the root user has ben enabled again.


#2

The script does not touch remotely your /etc/ssh/sshd_config file. It does not enable, nor disable root.

The fix for this should be relatively straight forward and you copy and paste to apply the following, this should patch you up. This is an over site on my wherein the proper command form those versions is upgradeQuickBox and not updateQuickBox.

user=$(cat /etc/apache2/master.txt)
rutorrent=/srv/rutorrent/
local_setup=/root/QuickBox/setup/
Reth0=$(ifconfig | grep -m 1 "Link encap" | sed 's/[ \t].*//;/^\(lo\|\)$/d' | awk '{ print $1 '});
IFACE=$(echo -n "${Reth0}");
cp /etc/apache2/master.txt ${rutorrent}home/db/master.txt
printf "${IFACE}" > ${rutorrent}home/db/interface.txt
rm /etc/sudoers
  cp ${local_setup}templates/sudoers.template /etc/sudoers
  awk -v username="${user}" '/^root/ && !x {print username    " ALL=(ALL:ALL) NOPASSWD: ALL"; x=1} 1' /etc/sudoers > /tmp/sudoers;mv /tmp/sudoers /etc
echo "*/1 * * * * root bash /usr/local/bin/quickbox/system/set_interface" > /etc/cron.d/set_interface
chmod +x /etc/cron.d/set_interface
chmod +x $(find /usr/local/bin/quickbox -type f)

#3

any time the bandwidth widget crashes i just do a server reboot and everything fixes it self.


#4

No, that could fix it after an update and a reboot then is not needed, it only takes around 1 minute for the net interface to update and then ajax does the rest. This is completely me at fault as the command for update was used when it should had been upgrade. It basically writes a blank username to sudoers and causing utter muckery (< not a word but it seems fitting).


#5

i like the word :smiley: fits. and oh maybe i am thinking when the widget stops showing up after sys update basicly just apache needing restarted but i say why not just reboot, i missed the part about the sudo users


#6

Thank you. JMSolo. Your solution fixed my problem in seconds.

I have just one suggestion for the next version: Leave the tabs “SERVICE STATUS” and “SERVICE CONTROLLER” open by default.


#7

Noted I had been contemplating this after the addition to give them open/close abilities. Keeping them closed is slightly aggravating when you want to keep an eye on them… especially as over the next couple of weeks, there will be more toggles in those zones.